题目1001:A+B for Matrices

Posted watchfree

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了题目1001:A+B for Matrices相关的知识,希望对你有一定的参考价值。

题目1001A+B for Matrices

时间限制:秒内存限制:32 

题目描述:

    This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

    The input consists of several test cases, each starts with a pair of positive integers M and N (10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

    The input is terminated by a zero M and that case must NOT be processed.

输出:

    For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:

2 2

1 1

1 1

-1 -1

10 9

2 3

1 2 3

4 5 6

-1 -2 -3

-4 -5 -6

0

样例输出:

1

5

 

----------------

代码有bug,测试数据不够严谨.  AC了。。。。

----------------------------------------------------

import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
        // TODO Auto-generated method stub
        Scanner sc=new Scanner(System.in);
        while(sc.hasNext()){
            int m=sc.nextInt();
            if(m==0)break;
            int n=sc.nextInt();
            int a[][]=new int[m][n];
            int b[][]=new int[m][n];
            int c[][]=new int[m][n];
            int zorerow=0;
            int zorecol=0;
            for(int i=0;i<m;i++)
                for(int j=0;j<n;j++)
                    a[i][j]=sc.nextInt();
            for(int i=0;i<m;i++)
                for(int j=0;j<n;j++){
                    b[i][j]=sc.nextInt();
                    c[i][j]=a[i][j]+b[i][j];
                }
            
            int temp=0;
            int tmp=0;
            for(int i=0;i<m;i++){
                for(int j=0;j<n;j++){
                  temp+=c[i][j];
                }
                if(temp==0)zorerow++;
                temp=0;
            }
            for(int j=0;j<n;j++){
                for(int i=0;i<m;i++){
                  tmp+=c[i][j];
                }
                if(tmp==0)zorerow++;
                tmp=0;
            }
                
            System.out.println(zorerow+zorecol);
        }

    }

}

 

以上是关于题目1001:A+B for Matrices的主要内容,如果未能解决你的问题,请参考以下文章

1001.A+B for Matrices

最长公共子序列

论文笔记-Augmented Lagrange Multiplier Method for Recovery of Low-Rank Matrices

论文笔记-Augmented Lagrange Multiplier Method for Recovery of Low-Rank Matrices

论文笔记-Augmented Lagrange Multiplier Method for Recovery of Low-Rank Matrices

PAT-甲级-1001-A+B for Polynomials