hdu3555 Bomb (数位dp入门题)

Posted xiepingfu

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu3555 Bomb (数位dp入门题)相关的知识,希望对你有一定的参考价值。

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 19698    Accepted Submission(s): 7311

Problem Description

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input

The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.

Output

For each test case, output an integer indicating the final points of the power.

Sample Input

3 1 50 500

Sample Output

0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.

代码(dfs解法):

#include<iostream>
#include<cstring>
#define LL long long
using namespace std;

LL bit[25], dp[25][2];

LL dfs(int pos, int is4, int lim)
{
    if(pos<0) return 1;
    if(!lim && dp[pos][is4]!=-1) return dp[pos][is4];
    int las=lim?bit[pos]:9;
    LL res=0;
    for(int i=0; i<=las; ++i)
        if(!(is4 && i==9))
            res+=dfs(pos-1, i==4, lim&&i==las);
    if(!lim) dp[pos][is4]=res;
    return res;
}

int main()
{
    int T;
    memset(dp, -1, sizeof(dp));
    cin>>T;
    while(T--)
    {
        LL n;
        cin>>n;
        LL len=0, m=n;
        while(n)
        {
            bit[len++]=n%10;
            n/=10;
        }
        LL ans=m-dfs(len-1, 0, 1)+1;
        cout<<ans<<endl;
    }
    return 0;
}

 

以上是关于hdu3555 Bomb (数位dp入门题)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 3555 Bomb(数位dp)

HDU 3555Bomb 数位DP

Bomb HDU - 3555 (数位DP)

HDU - 3555 - Bomb(数位DP)

HDU 3555 Bomb (数位DP)

HDU 3555 Bomb (数位dp)