HDU 3336 Count the string (基础KMP)

Posted hinata_hajime

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 3336 Count the string (基础KMP)相关的知识,希望对你有一定的参考价值。

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.

InputThe first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
OutputFor each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.Sample Input
1
4
abab
Sample Output
6

题意为: 求每个前缀在字符串中出现的次数之和
分析:Next数组在KMP中的定义是 前缀和后缀的最大公共长度.
设ans为所求值 ans至少为len ,遍历Next数组,每次Next长度不为0时 就说明和前缀有公共部分 ans++;

代码如下:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

const int N = 1000002;
int Next[N];
char S[N], T[N];
int slen, tlen;//注意每次一定要计算长度
const int MOD=1e4+7;
void getNext()
{
    int j, k;
    j = 0; k = -1; Next[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
            Next[++j] = ++k;
        else
            k = Next[k];

}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&tlen);
        scanf("%s",T);
        getNext();
        int ans=tlen%MOD;
        for(int i=2;i<=tlen;i++){
            if(Next[i]>0)
            ans=(ans+1)%MOD;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

以上是关于HDU 3336 Count the string (基础KMP)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 3336 Count the string

HDU 3336 Count the string

hdu 3336 Count the string

HDU 3336 Count the string

HDU 3336 Count the string (基础KMP)

HDU - 3336 Count the string (扩展kmp)