Hdu 2119 Matrix

Posted Alex丶Baker

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Hdu 2119 Matrix相关的知识,希望对你有一定的参考价值。

Matrix

Problem Description
Give you a matrix(only contains 0 or 1),every time you can select a row or a column and delete all the ‘1‘ in this row or this column .

Your task is to give out the minimum times of deleting all the ‘1‘ in the matrix.
 

 

Input
There are several test cases.

The first line contains two integers n,m(1<=n,m<=100), n is the number of rows of the given matrix and m is the number of columns of the given matrix.
The next n lines describe the matrix:each line contains m integer, which may be either ‘1’ or ‘0’.

n=0 indicate the end of input.
 

 

Output
For each of the test cases, in the order given in the input, print one line containing the minimum times of deleting all the ‘1‘ in the matrix.
 

 

Sample Input
3 3 0 0 0 1 0 1 0 1 0 0
 

 

Sample Output
2
 

 

#include <cstdio>
#include <cstring>
using namespace std;
int n,m,s,t,ans,w[2333][2333],a[1000000];
bool vis[100000];

inline void read(int &now)
{
    char ch; ch=getchar(); now=0;
    while(ch>9||ch<0) ch=getchar();
    while(ch>=0&&ch<=9) now=now*10+ch-0,ch=getchar();
}

int find(int x)
{
    for(int i=1;i<=m;i++)
    {
        if(w[x][i]&&!vis[i])
        {
            vis[i]=true;
            if(!a[i]||find(a[i]))
            {
                a[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d",&n)&&n)
    {
        if(!n) break ;
        scanf("%d",&m);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                scanf("%d",&w[i][j]);
        for(int i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(find(i)) ans++;
        }
        printf("%d\n",ans);
        memset(w,0,sizeof(w));
        memset(a,0,sizeof(a));
        ans=0;
    }
    return 0;
}

 

以上是关于Hdu 2119 Matrix的主要内容,如果未能解决你的问题,请参考以下文章

HDU——2119 Matrix

HDU——T 2119 Matrix

Hdu 2119 Matrix

HDU-2119-Matrix(最大匹配)

二分图匹配入门专题1D - Matrix hdu2119最小顶点覆盖

Client / Server Interoperability Support Matrix for Different Oracle Versions (Doc ID 207303.1)(代码片段