hdu 1075 What Are You Talking About

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1075 What Are You Talking About相关的知识,希望对你有一定的参考价值。

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 24489    Accepted Submission(s): 8240


Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn\'t know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
 

 

Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian\'s language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian\'s language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can\'t find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(\' \'), tab(\'\\t\'), enter(\'\\n\') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that\'s also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 

 

Output
In this problem, you have to output the translation of the history book.
 

 

Sample Input
START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i\'m fiwo riwosf.
i fiiwj fnnvk!
END
 

 

Sample Output
hello, i\'m from mars.
i like earth!
 
Hint
Huge input, scanf is recommended.
 

 

Author
Ignatius.L
 
 
trie树或者map
处理好了就是水题。
然而我已经接近神了 。。

屠龙宝刀点击就送

#include <iostream>
#include <string>
#include <cstdio>
#include <cstring>
#define N 1000001
using std::string;
using std::cout;
char a[N][27];
bool flag=false;
int trie[N][27],num[N],siz=1;
inline void ins(int Num,char *a)
{
    int p=1;
    for(char *q=a;*q;++q)
    {
        int id=*q-\'a\';
        if(!trie[p][id]) trie[p][id]=++siz;
        p=trie[p][id];
    }
    num[p]=Num;
}
inline int query(string b)
{
    int p=1,L=b.length();
    for(int i=0;i<L;++i)
    {
        int id=b[i]-\'a\';
        p=trie[p][id];
        if(!p) return 0; 
    }
    return num[p];
}
int main()
{
    char opt[15];
    scanf("%s",&opt);
    if(opt[0]==\'S\'&&opt[1]==\'T\'&&opt[2]==\'A\'&&opt[3]==\'R\'&&opt[4]==\'T\')
    { 
        char b[15];
        for(int i=1;;)
        {
            scanf("%s",a[i]);
            if(a[i][0]==\'E\'&&a[i][1]==\'N\'&&a[i][2]==\'D\'&&strlen(a[i])==3) break;
            i++;
            scanf("%s",&b);
            ins(i-1,b);
        }
    }
    scanf("%s",&opt);
    if(opt[0]==\'S\'&&opt[1]==\'T\'&&opt[2]==\'A\'&&opt[3]==\'R\'&&opt[4]==\'T\')
    {
        char ch=getchar();
        string now;now.clear();
        for(;;)
        {
            ch=getchar();
            for(;;ch=getchar())
            {
                if(ch>=\'a\'&&ch<=\'z\'||ch>=\'A\'&&ch<=\'Z\') now+=ch;
                else if(ch<\'a\'||ch>\'z\')
                {
                    int k=query(now);
                    if(!k) cout<<now;
                    else printf("%s",a[k]);
                    printf("%c",ch);
                    now.clear();
                }
                if(now=="END") {flag=1;break;}
            }
            if(flag) break;
            printf("\\n");
        }
    }
    return 0;
}

 

以上是关于hdu 1075 What Are You Talking About的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1075 What Are You Taking About

hdu 1075 What Are You Talking About

hdu 1075 What Are You Talking About (map)

HDU 1075 What Are You Talking About (Trie)

HDU1075 What Are You Talking About STL

HDU 1075 - What Are You Talking About