二分匹配入门专题1G - Asteroids poj3041最小顶点覆盖

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了二分匹配入门专题1G - Asteroids poj3041最小顶点覆盖相关的知识,希望对你有一定的参考价值。

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2
题意:有一个n*n的矩阵,输入k行数,每行数是一个点的坐标,一次性可以去掉矩阵一行或者一列的~~那个单词没查,反正就是去掉这些坐标点,问你最少的操作次数
思路:就是一个最小顶点覆盖的模板题,和杭电的2119一样。

 

#include<stdio.h>
#include<string.h>
#define N 550

int n,k;
int book[N],e[N][N],match[N];

int dfs(int u)
{
    int i;
    for(i = 1; i <= n; i ++)
    {
        if(!book[i]&&e[u][i])
        {
            book[i] = 1;
            if(!match[i]||dfs(match[i]))
            {
                match[i] = u;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int t1,t2,sum,i,j;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        sum = 0;
        memset(e,0,sizeof(e));
        memset(match,0,sizeof(match));
        for(i = 1; i <= k; i ++)
        {
            scanf("%d%d",&t1,&t2);
            e[t1][t2] = 1;
        }
        for(i = 1; i <= n; i ++)
        {
            memset(book,0,sizeof(book));
            if(dfs(i))
                sum ++;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

以上是关于二分匹配入门专题1G - Asteroids poj3041最小顶点覆盖的主要内容,如果未能解决你的问题,请参考以下文章

POJ 3041-Asteroids-二分图匹配

poj3041 Asteroids(二分图最小顶点覆盖二分图匹配)

二分图匹配入门专题1H - Marriage Media light oj 1184二分图最大匹配

POJ 3014:Asteroids(二分匹配,匈牙利算法)

二分图匹配入门专题1K - Going Home hdu1533km匹配

二分图匹配入门专题1F - COURSES poj1469最大匹配--匈牙利算法模板题