Bzoj3315 [Usaco2013 Nov]Pogo-Cow(luogu3089)

Posted Soda

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Bzoj3315 [Usaco2013 Nov]Pogo-Cow(luogu3089)相关的知识,希望对你有一定的参考价值。

3315: [Usaco2013 Nov]Pogo-Cow

Time Limit: 3 Sec  Memory Limit: 128 MB
Submit: 352  Solved: 181
[Submit][Status][Discuss]

Description

In an ill-conceived attempt to enhance the mobility of his prize cow Bessie, Farmer John has attached a pogo stick to each of Bessie‘s legs. Bessie can now hop around quickly throughout the farm, but she has not yet learned how to slow down. To help train Bessie to hop with greater control, Farmer John sets up a practice course for her along a straight one-dimensional path across his farm. At various distinct positions on the path, he places N targets on which Bessie should try to land (1 <= N <= 1000). Target i is located at position x(i), and is worth p(i) points if Bessie lands on it. Bessie starts at the location of any target of her choosing and is allowed to move in only one direction, hopping from target to target. Each hop must cover at least as much distance as the previous hop, and must land on a target. Bessie receives credit for every target she touches (including the initial target on which she starts). Please compute the maximum number of points she can obtain.

一个坐标轴有N个点,每跳到一个点会获得该点的分数,并只能朝同一个方向跳,但是每一次的跳跃的距离必须不小于前一次的跳跃距离,起始点任选,求能获得的最大分数。

Input

* Line 1: The integer N.

* Lines 2..1+N: Line i+1 contains x(i) and p(i), each an integer in the range 0..1,000,000.

Output

* Line 1: The maximum number of points Bessie can receive.

Sample Input

6
5 6
1 1
10 5
7 6
4 8
8 10

INPUT DETAILS: There are 6 targets. The first is at position x=5 and is worth 6 points, and so on.

Sample Output

25
OUTPUT DETAILS: Bessie hops from position x=4 (8 points) to position x=5 (6 points) to position x=7 (6 points) to position x=10 (5 points).

从坐标为4的点,跳到坐标为5的,再到坐标为7和,再到坐标为10的。
技术分享
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 101
int n,ans;
struct node{
    int s,v;
}a[maxn];
int cmp(node x,node y){return x.s<y.s;}
void dfs1(int now,int limit,int sum){
    ans=max(ans,sum);
    if(now>n)return;
    for(int i=now+1;i<=n;i++){
        if(a[i].s-a[now].s<limit)continue;
        else dfs1(i,a[i].s-a[now].s,sum+a[i].v);
    }
}
void dfs2(int now,int limit,int sum){
    ans=max(ans,sum);
    if(now<1)return;
    for(int i=now-1;i>=1;i--){
        if(a[now].s-a[i].s<limit)continue;
        else dfs2(i,a[now].s-a[i].s,sum+a[i].v);
    }
}
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d%d",&a[i].s,&a[i].v);
    sort(a+1,a+n+1,cmp);
    for(int i=1;i<=n;i++){
        dfs1(i,0,a[i].v);//向右 
        dfs2(i,0,a[i].v);//向左 
    }
    printf("%d",ans);
}
36分 暴力

 

以上是关于Bzoj3315 [Usaco2013 Nov]Pogo-Cow(luogu3089)的主要内容,如果未能解决你的问题,请参考以下文章

bzoj3312[Usaco2013 Nov]No Change*

bzoj1742[Usaco2005 nov]Grazing on the Run 边跑边吃草*&&bzoj3074[Usaco2013 Mar]The Cow Run*

bzoj3312: [Usaco2013 Nov]No Change

BZOJ 3314 [Usaco2013 Nov]Crowded Cows:单调队列

BZOJ 1230 [Usaco2008 Nov]lites 开关灯:线段树异或

BZOJ 1618: [Usaco2008 Nov]Buying Hay