二分图匹配入门专题1F - COURSES poj1469最大匹配--匈牙利算法模板题

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了二分图匹配入门专题1F - COURSES poj1469最大匹配--匈牙利算法模板题相关的知识,希望对你有一定的参考价值。

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

题意:输入p门课和n个学生,共1-p行,每行先输入学生总数n,再输入学生编号,问,能否满足,每个学生只选一门课,每门课有一个学生。
思路:又是最大匹配的水题,我很怀疑学长这次是先把各个oj上的水题放到前10道,然后后面的就6到飞起的那种
#include<stdio.h>
#include<string.h>
#define N 330
#define M 330
int e[N][M],book[M],match[M];
int n,m;
int dfs(int u)
{
    int i;
    for(i = 1; i <= m; i ++)
    {
        if(!book[i]&&e[u][i])
        {
            book[i] = 1;
            if(!match[i]||dfs(match[i]))
            {
                match[i] = u;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i,j,t2,sum,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(match,0,sizeof(match));
        memset(e,0,sizeof(e));
        scanf("%d%d",&n,&m);
        for(i = 1; i <= n; i ++)
        {
            scanf("%d",&sum);
            for(j = 1;j <= sum; j ++)
            {
                scanf("%d",&t2);
                e[i][t2] = 1;
            }
        }
        sum = 0;
        for(i = 1; i <= n; i ++)
        {
            memset(book,0,sizeof(book));
            if(dfs(i))
                sum ++;
        }
        if( sum == n)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

以上是关于二分图匹配入门专题1F - COURSES poj1469最大匹配--匈牙利算法模板题的主要内容,如果未能解决你的问题,请参考以下文章

二分图匹配入门专题1K - Going Home hdu1533km匹配

二分图匹配入门专题1D - Matrix hdu2119最小顶点覆盖

二分图匹配入门专题1poj3686 km+思维建图

二分图匹配入门专题1L - Card Game hdu 3722km算法

二分图匹配入门专题1E - Air Raid hdu1151最小路径覆盖

二分图匹配入门专题1I - Hiding Gold light oj 1152二分图匹配-------------------我是终于不那么水的水题分割线------------------(代码片