HDU 4027 Can you answer these queries?(线段树/区间不等更新)

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 4027 Can you answer these queries?(线段树/区间不等更新)相关的知识,希望对你有一定的参考价值。

传送门

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 18290    Accepted Submission(s): 4308

Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10

1 2 3 4 5 6 7 8 9 10

5

0 1 10

1 1 10

1 1 5

0 5 8

1 4 8

Sample Output

Case #1:

19

7

6

思路

题意:有N个数,有两种操作,当T = 0时,区间L到R的数都变为自己的开方(向下取整),当 T = 1时,计算出区间L到R的和。

思路:由于数最大不超过2的63次方,因此开六次就为1,因此通过lazy数组记录当前的数能否继续开放下去,不能的话,就不必更新,因为一直是1不变。

 

#include<bits/stdc++.h>
using namespace std;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
typedef __int64 LL;
const int maxn = 100005;
LL sum[maxn<<2];
bool lazy[maxn<<2];

void PushUp(int rt){
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
    lazy[rt] = lazy[rt << 1] && lazy[rt << 1 | 1];
}

void build(int l,int r,int rt){
    if (l == r){
        scanf("%I64d",&sum[rt]);
        return;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}

void upd(int L,int R,int l,int r,int rt){
    if (l == r){
        sum[rt] = sqrt(sum[rt]);
        if (sum[rt] <= 1)   lazy[rt] = 1;
        return;
    }
    int m = (l + r) >> 1;
    if (L <= m && !lazy[rt << 1]) upd(L,R,lson);
    if (R > m && !lazy[rt << 1 | 1])  upd(L,R,rson);
    PushUp(rt);
}

LL qry(int L,int R,int l,int r,int rt){
    if (L <= l && r <= R){
        return sum[rt];
    }
    LL ret = 0;
    int m = (l + r) >> 1;
    if (L <= m) ret += qry(L,R,lson);
    if (R > m)  ret += qry(L,R,rson);
    return ret;
}

int main(){
    int cases = 1;
    int N,M,T,a,b;
    while (~scanf("%d",&N)){
        memset(lazy,false,sizeof(lazy));
        memset(sum,0,sizeof(sum));
        printf("Case #%d:\n",cases++);
        build(1,N,1);
        scanf("%d",&M);
        while (M--){
            scanf("%d%d%d",&T,&a,&b);
            if (a > b)  swap(a,b);
            if (T == 0){
                upd(a,b,1,N,1);
            }
            else{
                printf("%I64d\n",qry(a,b,1,N,1));
            }
        }
        printf("\n");
    }
    return 0;
}

  

#include<bits/stdc++.h>
using namespace std;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
typedef __int64 LL;
const int maxn = 100005;
LL sum[maxn];

void PushUp(int rt){
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void build(int l,int r,int rt){
    if (l == r){
        scanf("%I64d",&sum[rt]);
        return;
    }
    int m = (l + r) >> 1;
    build(lson);
    build(rson);
    PushUp(rt);
}

void upd(int L,int R,int l,int r,int rt){
    if (sum[rt] == r - l + 1)   return;
    if (l == r){
        sum[rt] = sqrt(sum[rt]);
        return;
    }
    int m = (l + r) >> 1;
    if (L <= m) upd(L,R,lson);
    if (R > m)  upd(L,R,rson);
    PushUp(rt);
}

LL qry(int L,int R,int l,int r,int rt){
    if (L <= l && r <= R){
        return sum[rt];
    }
    LL ret = 0;
    int m = (l + r) >> 1;
    if (L <= m) ret += qry(L,R,lson);
    if (R > m)  ret += qry(L,R,rson);
    return ret;
}

int main(){
    int cases = 1;
    int N,M,T,a,b;
    while (~scanf("%d",&N)){
        printf("Case #%d:\n",cases++);
        build(1,N,1);
        scanf("%d",&M);
        while (M--){
            scanf("%d%d%d",&T,&a,&b);
            if (a > b)	swap(a,b);
            if (T == 0){
                upd(a,b,1,N,1);
            }
            else{
                printf("%I64d\n",qry(a,b,1,N,1));
            }
        }
    }
    return 0;
}

  

以上是关于HDU 4027 Can you answer these queries?(线段树/区间不等更新)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 4027 Can you answer these queries? (线段树)

HDU-4027 Can you answer these queries?(线段树区间开方)

HDU 4027 Can you answer these queries?

Can you answer these queries? HDU - 4027

HDU 4027 Can you answer these queries?(线段树)

HDU4027 Can you answer these queries?