XTU1236 Fraction

Posted gccbuaa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了XTU1236 Fraction相关的知识,希望对你有一定的参考价值。

Fraction

Accepted : 124
Submit : 806
Time Limit : 1000 MS
Memory Limit : 65536 KB

Fraction

Problem Description:

Everyone has silly periods, especially for RenShengGe. It‘s a sunny day, no one knows what happened to RenShengGe, RenShengGe says that he wants to change all decimal fractions between 0 and 1 to fraction. In addtion, he says decimal fractions are too complicate, and set that  is much more convient than 0.33333... as an example to support his theory.

So, RenShengGe lists a lot of numbers in textbooks and starts his great work. To his dissapoint, he soon realizes that the denominator of the fraction may be very big which kills the simplicity that support of his theory.

But RenShengGe is famous for his persistence, so he decided to sacrifice some accuracy of fractions. Ok, In his new solution, he confines the denominator in [1,1000] and figure out the least absolute different fractions with the decimal fraction under his restriction. If several fractions satifies the restriction, he chooses the smallest one with simplest formation.

Input

The first line contains a number T(no more than 10000) which represents the number of test cases.

And there followed T lines, each line contains a finite decimal fraction x that satisfies .

Output

For each test case, transform x in RenShengGe‘s rule.

Sample Input

3
0.9999999999999
0.3333333333333
0.2222222222222

Sample Output

1/1
1/3
2/9

tip

You can use double to save x;


Source

XTU OnlineJudge

题意:把小数化成最接近他的分数,要求最简形式。

分析:枚举分母。每次得到的分子与初始值相比較误差最小的就是答案。


<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define MAXN 100010

int main()
{
    int T;
    double s,minx;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf",&s);
        minx = s;
        int a=0,b=1;
        for(int i=1; i<=1000; i++)
        {
            int j = i*s+0.5;
            double f = j*1.0/i;
            double p = fabs(f-s);
            if(minx > p)
            {
                minx = p;
                a = j;
                b = i;
            }
        }
        int r = __gcd(a, b);
        printf("%d/%d\n",a/r,b/r);
    }
    return 0;
}
</span>


以上是关于XTU1236 Fraction的主要内容,如果未能解决你的问题,请参考以下文章

xtu 1035 与xtu 1036 两道出栈入栈题目,蛮有趣的

xtu怎么设置永久有效

MySQL 5.5 '二进制日志未打开',错误代码:1236

由于错误代码 1236,无法启动 debezium MySQL 连接器

使用XTU降低CPU功耗,自动执行不失效

xtu如何保存超频设置