POJ 1523 SPF 割点 Tarjan

Posted joeylee97

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1523 SPF 割点 Tarjan相关的知识,希望对你有一定的参考价值。

SPF
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 9317   Accepted: 4218

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 
技术分享

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
typedef long long LL;
#define MAXN 1009
#define N 100
/*
求割点的个数 和割点被去掉之后联通快的个数
//删除割点u产生的连通数目为:u所在的连通分量数目+与u所连接的割边的数目+1(边:fa->u)
*/
struct edge
{
    //edge(int _t,int _next):to(_t),next(_next){}
    int to, next;
};
edge E[MAXN * MAXN];
int index, dfn[MAXN], low[MAXN], s[MAXN], head[MAXN], cnt, Max, cas = 1, root;
bool flag;
void Init()
{
    index = 0;
    Max = -1;
    cnt = 0;
    flag = false;
    memset(head, -1, sizeof(head));
    memset(dfn, 0, sizeof(dfn));
    memset(s, 0, sizeof(s));
    memset(low, 0, sizeof(low));
}
void add_edge(int u, int v)
{
    E[cnt].to = v;
    E[cnt].next = head[u];
    head[u] = cnt++;
    Max = max(max(u, v), Max);
}

void tarjan(int pre, int u)
{
    int son = 0;
    low[u] = dfn[u] = ++index;
    for (int i = head[u]; i != -1; i = E[i].next)
    {
        int v = E[i].to;
        if (!dfn[v])
        {
            tarjan(u, v);
            son++;
            low[u] = min(low[v], low[u]);
            if ((u == root&&son > 1) || (u != root&&low[v] >= dfn[u]))
            {
                flag = true;
                s[u]++;
            }
        }
        else if (v != pre)
            low[u] = min(low[u], dfn[v]);
    }
}

int main()
{
    int f, t;
    while (1)
    {
        Init();
        while (scanf("%d",&f), f)
        {
            scanf("%d", &t);
            add_edge(f, t);
            add_edge(t, f);
        }
        if (Max == -1)
            break;
        root = Max;
        tarjan(-1, Max);
        printf("Network #%d\n",cas++);
        if (!flag)
        {
            printf("  No SPF nodes\n");
        }
        else
        {
            for (int i = 1; i <= Max; i++)
                if (s[i] > 0)
                    printf("  SPF node %d leaves %d subnets\n", i, s[i] + 1);
        }
        printf("\n");
    }
}

 






以上是关于POJ 1523 SPF 割点 Tarjan的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1523 SPF 解题报告

POJ1523 SPF(割点)

POJ 1523 SPF 求割点的好(板子)题!

POJ-1523-SPF(求割点)

poj1523:SPF——题解

POJ1523SPF[无向图割点]