hdu 1505 City Game

Posted 日拱一卒 功不唐捐

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1505 City Game相关的知识,希望对你有一定的参考价值。

City Game

http://acm.hdu.edu.cn/showproblem.php?pid=1505

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you‘re building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.
 
Input
The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.
 
Output
For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.
 
Sample Input
2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F
 
5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R
 
Sample Output
45
0
 
Source
 
Recommend
zl   |   We have carefully selected several similar problems for you:  1069 1203 1176 1231 1087 
 
题意:在矩阵里找最大的由F组成的子矩阵
 
枚举行
令a[i]表示,到了这一行,第i列,最大‘F’后缀个数
然后单调队列做n遍广告印刷问题即可
 
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 1001
using namespace std;
int a[N],b[N];
int q[N],tmp[N],head,tail;
int l[N],r[N];
int ans;
int n,m;
char s[2];
void monotonous(int *c,int *d)
{
    int h=1;
    while(h<=m && !c[h]) h++;
    if(h>m) return;
    q[0]=c[h]; tmp[0]=h; 
    head=0; tail=1;
    for(int i=2;i<=m;i++)
    {
        if(!c[i])
            while(head<tail) d[tmp[head++]]=i-1;
        else if(head==tail) q[tail]=c[i],tmp[tail++]=i;
        else
        {
            if(c[i]<q[tail-1]) 
            while(head<tail && q[tail-1]>c[i])    d[tmp[--tail]]=i-1;
            q[tail]=c[i];
            tmp[tail++]=i;
        }
    }
    while(head<tail) d[tmp[head++]]=tmp[tail-1];
}
int main()
{
    int T; char ch; 
    scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {    
        ans=0; 
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%s",s);
                if(s[0]==F) a[j]++,b[m-j+1]++;
                else a[j]=b[m-j+1]=0;
            }
            monotonous(a,r);
            monotonous(b,l);
            for(int i=1;i<=m;i++) tmp[i]=l[i];
            for(int i=1;i<=m;i++) l[m-i+1]=m-tmp[i]+1;
            for(int i=1;i<=m;i++) ans=max(ans,(r[i]-l[i]+1)*a[i]);
        }
        printf("%d\n",ans*3);
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
    }
}

 

以上是关于hdu 1505 City Game的主要内容,如果未能解决你的问题,请参考以下文章

HDU - 1505 City Game(dp)

HDU 1054 Strategic Game(无向二分图的最大匹配)

City Game(动态规划)

UVA1330 City Game

Uva1330 / poj1964 City Game

uvalive 3029 City Game