HDU 1059 Dividing

Posted 十年换你一句好久不见

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1059 Dividing相关的知识,希望对你有一定的参考价值。

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26842    Accepted Submission(s): 7687

Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 
Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0‘‘. The maximum total number of marbles will be 20000.

The last line of the input file will be ``0 0 0 0 0 0‘‘; do not process this line.
 
Output
For each colletcion, output ``Collection #k:‘‘, where k is the number of the test case, and then either ``Can be divided.‘‘ or ``Can‘t be divided.‘‘.

Output a blank line after each test case.
 
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0
 
Sample Output
Collection #1: Can‘t be divided.
 
Collection #2: Can be divided.
判断这些物品能否被平均分配
多重背包问题
#include <iostream> 
#include <algorithm> 
#include <cstring> 
#include <cstdio>
#include <vector> 
#include <queue> 
#include <cstdlib> 
#include <iomanip>
#include <cmath> 
#include <ctime> 
#include <map> 
#include <set> 
using namespace std; 
#define lowbit(x) (x&(-x)) 
#define max(x,y) (x>y?x:y) 
#define min(x,y) (x<y?x:y) 
#define MAX 100000000000000000 
#define MOD 1000000007
#define pi acos(-1.0) 
#define ei exp(1) 
#define PI 3.141592653589793238462
#define ios() ios::sync_with_stdio(false)
#define INF 1044266558
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
int a[9];
int dp[100009];
int main()
{
    int cast=0;
    while(scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]))
    {
        if(a[1]==0 && a[2]==0 && a[3]==0 && a[4]==0 && a[5]==0 && a[6]==0) break;
        printf("Collection #%d:\n",++cast);
        int sum=a[1]*1+a[2]*2+a[3]*3+a[4]*4+a[5]*5+a[6]*6;
        memset(dp,62,sizeof(dp));
        dp[0]=0;
        if(sum&1) printf("Can‘t be divided.\n\n");
        else
        {
            sum/=2;
            for(int i=1;i<=6;i++)
            {
                for(int k=1;a[i];k*=2)
                {
                    if(a[i]<k) k=a[i];
                    for(int j=sum;j>=k*i;j--)
                    {
                        dp[j]=min(dp[j],dp[j-k*i]+k*i);
                    }
                    a[i]-=k;
                }
            }
            if(dp[sum]==sum) printf("Can be divided.\n\n");
            else printf("Can‘t be divided.\n\n");
        }
    }
    return 0;
}

 

以上是关于HDU 1059 Dividing的主要内容,如果未能解决你的问题,请参考以下文章

hdu1059 Dividing

背包专题G - Dividing hdu 1059多重背包

hdu 1059 Dividing bitset 多重背包

POJ 1014 / HDU 1059 Dividing 多重背包+二进制分解

poj1014 hdu1059 Dividing 多重背包

[多重背包+二进制优化]HDU1059 Dividing