ZOJ 1002 DFS

Posted 灬从此以后灬

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了ZOJ 1002 DFS相关的知识,希望对你有一定的参考价值。

Fire Net

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

 

技术分享

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

题意  n*n的地图,‘.‘表示空地,‘X‘表示墙,现在往地图上放置炮塔,要求两两炮塔不能同行同列(除非之间有墙),给定一种地图,问这个地图最多可以放置多少个炮塔?
解析

AC代码
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
const int maxn=100000;
using namespace std;
typedef long long ll;
int n;
int ans;             //最多可放炮塔数
char map[5][5];
int canput(int r,int c)            //判断(r,c)位置能否放置炮塔
{
    int i;                                  //因为行列是递增的,因此只需向上和向左搜索是否有碉堡即可
    for(i=r-1;i>=0&&map[i][c]!=X;i--)      //向上
    {
        if(map[i][c]==O)
            return 0;
    }
    for(i=c-1;i>=0&&map[r][i]!=X;i--)    // 向左
    {
        if(map[r][i]==O)
            return 0;
    }
    return 1;
}
void solve(int k,int current)
{
    int x,y;
    if(k==n*n)              //整个图判断完毕
    {
        if(current>ans)      //更新最优解
        {
            ans=current;
            return;
        }
    }
    else
    {
        x=k/n;                             //将单元数转化为坐标
        y=k%n;
        if(map[x][y]==.&& canput(x,y)==1)   //如果单元格可以放置炮塔
        {
            map[x][y]=O;                    //放置一个炮塔
            solve(k+1,current+1);             //递归到下一个单元格
            map[x][y]=.;                     //恢复单元格 ,回溯
        }
        solve(k+1,current);               //本单元格不能放置炮塔
    }
}
int main(int argc, char const *argv[])
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",map[i]);
        }
        solve(0,0);
        printf("%d\n",ans);
    }
    return 0;
}

 






以上是关于ZOJ 1002 DFS的主要内容,如果未能解决你的问题,请参考以下文章

ZOJ1002 —— 深度优先搜索

[ZOJ1002] Fire Net

ZOJ1008 一个简单的dfs回溯问题,为啥老是出现超时错误,我和同样可以通过的代码思路基本一样

[zoj4045][思维+dfs]

ZOJ 1709 Oil Deposits(dfs,连通块个数)

ZOJ 1457 Prime Ring Problem(dfs+剪枝)