zoj_3203 (三分)
Posted
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了zoj_3203 (三分)相关的知识,希望对你有一定的参考价值。
Description
Compared to wildleopard‘s wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.
Input
The first line of the input contains an integer T (T <= 100), indicating the number of cases.
Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.
Output
For each test case, output the maximum length of mildleopard‘s shadow in one line, accurate up to three decimal places..
Sample Input
3
2 1 0.5
2 0.5 3
4 3 4
Sample Output
1.000
0.750
4.000
求影子长度的最大值,哦,最大值,那就是三分喽。
根据相似三角形边的关系,推导出公式影长:D-x+H-(H-h)*D/x;
#include<bits/stdc++.h>
using namespace std;
const double esp = 1e-10;
double H,h,D,L,R,mid,midd;
double f(double x){
return D-x+H-(H-h)*D/x;
}
int main(){
int T;
scanf("%d",&T);
while(T--){
scanf("%lf %lf %lf",&H,&h,&D);
mid = midd = 0.0;
L=0.0; R=D;
while(R-L>esp){
mid=L+(R-L)/2.0;
midd=mid+(R-mid)/2.0;
if(f(mid)<f(midd))
L=mid;
else
R=midd;
}
printf("%.3lf\\n",f(L));
}
return 0;
}
以上是关于zoj_3203 (三分)的主要内容,如果未能解决你的问题,请参考以下文章
BZOJ3203 SDOI2013 保护出题人 凸包+三分法