Periodic Strings(周期串)

Posted 糖小俊

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Periodic Strings(周期串)相关的知识,希望对你有一定的参考价值。

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

 

Write a program to read a character string and determine its smallest period.

 

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

 

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

 

Sample Input

 

1

HoHoHo

Sample Output

2
如果一个字符串可以由某个长度为k的字符串重复多次得到,则称该串以k为周期。例如,abcabcabc以3为周期(注意,它也以6和9为周期)
输入一个长度不超过80的字符串,输出其最小周期。

#include<stdio.h>
#include<string.h>
char s[100];
int main()
{
    int t,ok;
    scanf("%d",&t);    
    while(t--){
        scanf("%s",s);
        int n=strlen(s);
        for(int i=1;i<=n;i++){ //周期
            if(n%i==0){  //周期必须能够整除字符串长度,如ababab的周期为2,字符串长度为6,6%2=0,或者abcd的周期为4,字符串长度为4,4%4=0;
                ok=true;
                for(int j=i;j<n;j++){
                if(s[j]!=s[j%i]){ //根据周期比较字符串
                 ok=false; 
                 break;
                }
            }
            if(ok){
                printf("%d\n",i);
                break;
               }
            }
        }
        if(t!=0)
            printf("\n");
    }
    return 0;
}

 
































 

以上是关于Periodic Strings(周期串)的主要内容,如果未能解决你的问题,请参考以下文章

(UVA)455 --Periodic Strings(周期串)

UVA455 周期串(Periodic Strings)

UVa 455 - Periodic Strings 解题报告

E. K-periodic Garland DP | 贪心

uvaoj455Periodic Strings(枚举)

Periodic Strings UVA - 455