HDU - 2476 String painter

Posted 西北会法语

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU - 2476 String painter相关的知识,希望对你有一定的参考价值。

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?InputInput contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
OutputA single line contains one integer representing the answer.Sample Input

zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output

6
7
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

char s1[105],s2[105];
int dp[105][105],ans[105],i,j,k,len;

int main()
{
    while(~scanf("%s%s",s1,s2))
    {
        len = strlen(s1);
        memset(dp,0,sizeof(dp));
        for(j = 0; j<len; j++)
            for(i = j; i>=0; i--)
            {
                dp[i][j] = dp[i+1][j]+1;
                for(k = i+1; k<=j; k++)
                    if(s2[i]==s2[k])
                        dp[i][j] = min(dp[i][j],(dp[i+1][k]+dp[k+1][j]));
            }
        for(i = 0; i<len; i++)
            ans[i] = dp[0][i];
        for(i = 0; i<len; i++)
        {
            if(s1[i] == s2[i])
                ans[i] = ans[i-1];
            for(j = 0; j<i; j++)
                ans[i] = min(ans[i],ans[j]+dp[j+1][i]);
        }
        printf("%d\n",ans[len-1]);
    }

    return 0;
}

  

以上是关于HDU - 2476 String painter的主要内容,如果未能解决你的问题,请参考以下文章

hdu2476String painter (区间DP)

hdu 2476 String Painter

HDU 2476 String painter(区间dp)

HDU 2476 String painter

hdu 2476 String painter(区间dp)

String painter (hdu 2476 DP好题)