HDU 5305 Friends (DFS)

Posted wzjhoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5305 Friends (DFS)相关的知识,希望对你有一定的参考价值。


Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

 Total Submission(s): 163    Accepted Submission(s): 61


Problem Description
There are n people and m pairs of friends. For every pair of friends, they can choose to become online friends (communicating using online applications) or offline friends (mostly using face-to-face communication). However, everyone in these n people wants to have the same number of online and offline friends (i.e. If one person has x onine friends, he or she must have x offline friends too, but different people can have different number of online or offline friends). Please determine how many ways there are to satisfy their requirements.
 

Input
The first line of the input is a single integer T (T=100), indicating the number of testcases.

For each testcase, the first line contains two integers n (1n8) and m (0mn(n?1)2), indicating the number of people and the number of pairs of friends, respectively. Each of the next m lines contains two numbers x and y, which mean x and y are friends. It is guaranteed that xy and every friend relationship will appear at most once.
 

Output
For each testcase, print one number indicating the answer.
 

Sample Input
2 3 3 1 2 2 3 3 1 4 4 1 2 2 3 3 4 4 1
 

Sample Output
0 2
 

Source
2015 Multi-University Training Contest 2

题目大意:一些朋友关系可离线可在线,要求每一个人的离线朋友数等于在线朋友数

题目分析:数据量不大。直接爆搜。记录每一个点的度数,奇数的直接不可能,偶数的分成两个数组,c1[i]表示i的在线朋友数,c2[i]表示i的离线朋友数,然后一条边一条边搜即可了,注意一个剪枝。当一条边的两个端点有一个c值为0,则return

#include <cstdio>
#include <cstring>
bool mp[10][10];
int deg[10], c1[10], c2[10];
int n, m, cnt, ans;

struct EDGE
{
    int u, v;
}e[100000];

void DFS(int cur)
{
    if(cur == m + 1)
    {
        ans ++;
        return;
    }
    int v = e[cur].v;
    int u = e[cur].u;
    if(c1[u] && c1[v])
    {
        c1[u] --;
        c1[v] --;
        DFS(cur + 1);
        c1[u] ++;
        c1[v] ++;
    }
    if(c2[u] && c2[v])
    {
        c2[u] --;
        c2[v] --;
        DFS(cur + 1);
        c2[u] ++;
        c2[v] ++;
    }
    return;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T --)
    {
        cnt = 0;
        ans = 0;
        memset(deg, 0, sizeof(deg));
        memset(e, 0, sizeof(e));
        memset(c1, 0, sizeof(c1));
        memset(c2, 0, sizeof(c2));
        scanf("%d %d", &n, &m);
        for(int i = 1; i <= m; i++)
        {
            scanf("%d %d", &e[i].u, &e[i].v);
            deg[e[i].u] ++;
            deg[e[i].v] ++;
        }
        bool f = false;
        for(int i = 1; i <= n; i++)
        {
            c1[i] = c2[i] = deg[i] / 2;
            if(deg[i] & 1)
            {
                f = true;
                break;
            }
        }
        if(f)
        {
            printf("0\n");
            continue;
        }
        DFS(1);
        printf("%d\n", ans);
    }
}

 

以上是关于HDU 5305 Friends (DFS)的主要内容,如果未能解决你的问题,请参考以下文章

hdu5305 Friends(dfs,多校题)

hdu5305 Friends(dfs+map/hash)

HDU 5305Friends 多校第二场(双向DFS)

HDU 5305 Friends (搜索+剪枝) 2015多校联合第二场

[多校2015.02.1006 高斯消元] hdu 5305 Friends

HDU 5241 Friends (大数)