HDU3351 Seinfeld 贪心

Posted liguangsunls

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU3351 Seinfeld 贪心相关的知识,希望对你有一定的参考价值。

Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1368    Accepted Submission(s): 674


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

Sample Input
}{ {}{}{} {{{} ---
 

Sample Output
1. 2 2. 0 3. 1
 

Source

题意:给定一个括号序列,求最少经过多少操作能使其变为合法序列。操作仅仅能是把左括号变为右括号或者右括号变为左括号。

题解:每次读取一个字符,若是左括号。那么left++。若是右括号,那么left--,若left==0,那么须要一次操作以将右括号变为左括号。

#include <stdio.h>
#include <string.h>

#define maxn 2010

char str[maxn];

int main() {
	int i, left, op, cas = 1;
	while(scanf("%s", str), str[0] != '-') {
		left = op = 0;
		for(i = 0; str[i]; ++i) {
			if(str[i] == '{') ++left;
			else if(0 == left) {
				++left; ++op;
			} else --left;
		}
		op += left / 2;
		printf("%d. %d\n", cas++, op);
	}
	return 0;
}


以上是关于HDU3351 Seinfeld 贪心的主要内容,如果未能解决你的问题,请参考以下文章

Seinfeld(杭电3351)

POJ 3991 Seinfeld

hdu2037 今年暑假不AC[贪心][区间调度问题]

HDU 6034 Balala Power!(贪心 + 进制)

[HDU4864]Task (贪心)

hdu 4105 贪心思想