Wolf and Rabbit

Posted CountingStars

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Wolf and Rabbit相关的知识,希望对你有一定的参考价值。

gcd(最大公因数)和lcm(最小公倍数)

辗转相除法求a和b的最大公因数和最小公倍数:

最小公倍数=a*b/最大公约数;

求最大公因数:

 

int gcd(int a,int b)
{
    int temp;
    if (a<b)
    {
        temp=a;
        a=b;
        b=temp;
    }
    while (b!=0)
    {
        temp=a%b;
        a=b;
        b=temp;
    }
    return a;
}

 

求最小公倍数:

int lcm(int x,int y)
{
    return x*y/gcd(x,y);
}

题目:

There is a hill with n holes around. The holes are signed from 0 to n-1. 

技术分享


A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes. 

InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648). 
OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line. 
Sample Input

2
1 2
2 2

Sample Output

NO
YES

AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int gcd(int a,int b)
{
    int temp;
    if (a<b)
    {
        temp=a;
        a=b;
        b=temp;
    }
    while (b!=0)
    {
        temp=a%b;
        a=b;
        b=temp;
    }
    return a;
}

int main()
{

    int n,m;
    int t;
    cin>>t;
    while (t--)
    {
        int num=0;
        cin>>m>>n;
     int y = gcd(m,n);
        if (y==1)
            cout << "NO" << endl;
        else
            cout << "YES" << endl;
    }
    return 0;
}

 

 

 










以上是关于Wolf and Rabbit的主要内容,如果未能解决你的问题,请参考以下文章

E - Wolf and Rabbit

HDU 1222: Wolf and Rabbit

Wolf and Rabbit

HDU-1222 Wolf and Rabbit (欧几里得定理)

HDU 3046 Pleasant sheep and big big wolf(最小割)

HDU1849 Rabbit and Grass()