HDU - 1358 - Period (KMP)

Posted yutingliuyl

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU - 1358 - Period (KMP)相关的知识,希望对你有一定的参考价值。

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4325    Accepted Submission(s): 2087


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
3 aaa 12 aabaabaabaab 0
 

Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
 

Recommend
JGShining
 




也是一个KMP求周期的题目


与之前类似


不知道为啥next开成全局的就CE了,难道全局的就会和stl里的函数冲突。。


AC代码:

#include <map>
#include <set>
#include <cmath>
#include <deque>
#include <queue>
#include <stack>
#include <cstdio>
#include <cctype>
#include <string>
#include <vector>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long
#define INF 0x7fffffff
using namespace std;

int n;
char s[1000005];

int s_next[1000005];

int main() {
	int cas = 1;
	while(scanf("%d", &n) != EOF) {
		if(n == 0) break;
		
		memset(s_next, 0, sizeof(s_next));
		s_next[0] = -1;
		scanf("%s", s);
		int i = 0, j = -1;
		while(i < n) {
			if(j == -1 || s[i] == s[j]) s_next[++ i] = ++ j;
			else j = s_next[j];
		}
		
		printf("Test case #%d\n", cas ++);
		
		for(int i = 2; i <= n; i ++) {
			int t = i - s_next[i];
			if(i % t == 0 && i / t > 1) {
				printf("%d %d\n", i, i / t);
			}
		}
		printf("\n");
	}
	return 0;
}












以上是关于HDU - 1358 - Period (KMP)的主要内容,如果未能解决你的问题,请参考以下文章

Period HDU - 1358

hdu 1358 Period

HDU - 1358 Period

hdu-1358 Period

hdu 1358 Period(kmp)

hdu 1358 period KMP入门