hdu1301 Jungle Roads (最小生成树)

Posted claireyuancy

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu1301 Jungle Roads (最小生成树)相关的知识,希望对你有一定的参考价值。

Jungle Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5591    Accepted Submission(s): 4031


Problem Description
技术分享

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 
 

Sample Input
9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
 

Sample Output
216 30
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:  1162 1102 1217 php?

pid=1142" target="_blank" style="color:rgb(26,92,200); text-decoration:none">1142 1598 

 

Statistic | Submit | Discuss | Note

看着这道题那么长  非常吓人、

就是一个最小生成树。

我是大概读了一个题意。

。(英语不好)

然后看看输入  再看看上面的图 理解了题意......

kruskal算法写的。

#include <stdio.h>
#include <algorithm>
using namespace std;
struct node
{
	int a,b,cost;
}c[100];
int fa[30];
bool cmp(node x,node y)
{
	return x.cost<y.cost;
}
void init()
{
	for(int i=0;i<=26;i++)
	fa[i]=i;
}
int find(int x)
{
	if(fa[x]!=x) fa[x]=find(fa[x]);
	return fa[x];
}
int main()
{
	int n;
	while(scanf("%d",&n)&&n)
	{
		init();
		int t=0;
		for(int i=1;i<n;i++)
		{
			char ch1,ch2;
			int x,cos;
			getchar();
			scanf("%c %d",&ch1,&x);
			for(int j=0;j<x;j++)
			{
				getchar();
				scanf("%c %d",&ch2,&cos);
				c[t].a=ch1-'A',c[t].b=ch2-'A',c[t].cost=cos;
				t++;
			}
		}
		sort(c,c+t,cmp);
		int sum=0;
		for(int i=0;i<t;i++)
		{
			int x=find(c[i].a);
			int y=find(c[i].b);
			if(x!=y)
			fa[x]=y,sum+=c[i].cost;
		}
		printf("%d\n",sum);
	}
	return 0;
}




















以上是关于hdu1301 Jungle Roads (最小生成树)的主要内容,如果未能解决你的问题,请参考以下文章

hdu1301 Jungle Roads (最小生成树)

hdu1301 Jungle Roads 基础最小生成树

最小生成树 || HDU 1301 Jungle Roads

HDU - 1301Jungle Roads(并查集+最小生成树)(内附最小生成树两种算法 克鲁斯特尔算法&&普里姆算法)

hduoj-1301 Jungle Roads(最小生成树-克鲁斯卡尔和普里姆求解)

POJ - 1251 Jungle Roads(最小生成树)