hdu 1789 Doing Homework again 贪心

Posted yfceshi

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 1789 Doing Homework again 贪心相关的知识,希望对你有一定的参考价值。

题链:http://acm.hdu.edu.cn/showproblem.php?pid=1789

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8415    Accepted Submission(s): 4954


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
0 3 5
 

Author
lcy
 


题意:有n个任务,第一排是任务完毕的最后时刻,第二排是任务不在指定时刻完毕所受到的惩处。

做法:优先要做分高的,然后每一个任务找离自己近期的时间。且没有被占领的时间点去完毕这任务。假设在截止时间前已经没有空暇时间,就是不能完毕了。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map> 
 
struct work
{
	int d,s;
};
work wo[1010];

int cmp(work a,work b)
{
	//if(a.s!=b.s)
		return a.s>b.s;
//	return a.d>b.d;
}

map<int,bool>my;
int main()
{
	int n;
	int t;

	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		my.clear();
		for(int i=0;i<n;i++)
			scanf("%d",&wo[i].d);  
		for(int i=0;i<n;i++)
			scanf("%d",&wo[i].s);  
		int ans=0;
		sort(wo,wo+n,cmp); 
		 
		for(int i=0;i<n;i++)
		{
			while(1)
			{
				if(my.count(wo[i].d)==0)
				{
					my[wo[i].d]=1; 
					break;
				}
				wo[i].d--;
				if(wo[i].d==0)
				{
					ans+=wo[i].s;
					break;
				}
			} 
		} 
		printf("%d\n",ans);
	}
	return 0;
}

 
 



以上是关于hdu 1789 Doing Homework again 贪心的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1789 Doing Homework again(贪心)

HDU 1789 Doing Homework again

hdu 1789 Doing Homework again

hdu 1789 Doing Homework again 贪心

HDU 1789 - Doing Homework again - [贪心+优先队列]

HDU 1789 Doing Homework again