HDOJ 5418 Victor and World 状压DP

Posted claireyuancy

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDOJ 5418 Victor and World 状压DP相关的知识,希望对你有一定的参考价值。


水状压DP

Victor and World

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 407    Accepted Submission(s): 164


Problem Description
After trying hard for many years, Victor has finally received a pilot license. To have a celebration, he intends to buy himself an airplane and fly around the world. There are n countries on the earth, which are numbered from 1 to n. They are connected by m undirected flights, detailedly the i-th flight connects the ui-th and the vi-th country, and it will cost Victor‘s airplane wi L fuel if Victor flies through it. And it is possible for him to fly to every country from the first country.

Victor now is at the country whose number is 1, he wants to know the minimal amount of fuel for him to visit every country at least once and finally return to the first country.
 

Input
The first line of the input contains an integer T, denoting the number of test cases.
In every test case, there are two integers n and m in the first line, denoting the number of the countries and the number of the flights.

Then there are m lines, each line contains three integers uivi and wi, describing a flight.

1T20.

1n16.

1m100000.

1wi100.

1ui,vin.
 

Output
Your program should print T lines : the i-th of these should contain a single integer, denoting the minimal amount of fuel for Victor to finish the travel.
 

Sample Input
1 3 2 1 2 2 1 3 3
 

Sample Output
10
 

Source
 



/* ***********************************************
Author        :CKboss
Created Time  :2015年08月23日 星期日 10时27分21秒
File Name     :HDOJ5418.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <cassert>

using namespace std;

typedef long long int LL;

const int INF=0x3f3f3f3f;

int n,m;
int G[18][18];
int dp[18][1<<18];

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%d%d",&n,&m);
		memset(G,63,sizeof(G));
		for(int i=0;i<n;i++) G[i][i]=0;
		for(int i=0,a,b,c;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			a--; b--;
			G[a][b]=min(G[a][b],c);
			G[b][a]=min(G[b][a],c);
		}

		for(int k=0;k<n;k++)
			for(int i=0;i<n;i++)
				for(int j=0;j<n;j++)
					G[i][j]=min(G[i][j],G[i][k]+G[k][j]);
		memset(dp,63,sizeof(dp));

		dp[0][1]=0;
		for(int i=1;i<(1<<n);i++) /// status
		{
			for(int j=0;j<n;j++) /// from point
			{
				if(((1<<j)&i)!=0)
				{
					for(int k=0;k<n;k++) /// to point
					{
						if(((1<<k)&i)==0)
						{
							dp[k][((1<<k)|i)]=min(dp[k][((1<<k)|i)],dp[j][i]+G[j][k]);
						}
					}
				}
			}
		}
		int ans=INF;
		for(int i=0;i<n;i++)
		{
			ans=min(ans,dp[i][(1<<n)-1]+G[i][0]);
		}
		if(n==1) ans=0;
		printf("%d\n",ans);
	}
    return 0;
}


以上是关于HDOJ 5418 Victor and World 状压DP的主要内容,如果未能解决你的问题,请参考以下文章

HDU 5418 Victor and World 状压DP的TSP问题

hdu 5418 Victor and World (状压dp)

BestCoder Round #52 (div.2) HDU 5418 Victor and World (DP+状态压缩)

HDOJ 5421 Victor and String 回文串自己主动机

Victor and String[Bestcoder #52 1004](回文树)

codeforces 460D:Little Victor and Set