HDU3549_Flow Problem(网络流/EK)

Posted liguangsunls

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU3549_Flow Problem(网络流/EK)相关的知识,希望对你有一定的参考价值。

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 6987    Accepted Submission(s): 3262


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
Case 1: 1 Case 2: 2
 

Author
HyperHexagon

解题报告

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define N 30
#define inf 99999999
using namespace std;
int n,m,a[N],flow,pre[N];
int Edge[N][N];
queue<int >Q;
int bfs()
{
    while(!Q.empty())
    Q.pop();
    memset(a,0,sizeof(a));
    memset(pre,0,sizeof(pre));
    Q.push(1);
    pre[1]=1;
    a[1]=inf;
    while(!Q.empty())
    {
        int u=Q.front();
        Q.pop();
        for(int v=1;v<=n;v++)
        {
            if(!a[v]&&Edge[u][v]>0)
            {
                pre[v]=u;
                a[v]=min(Edge[u][v],a[u]);
                Q.push(v);
            }
        }
        if(a[n])break;
    }
    if(!a[n])
    return -1;
    else return a[n];
}
void ek()
{
    int a,i;
    while((a=bfs())!=-1)
    {
        for(i=n;i!=1;i=pre[i])
        {
            Edge[pre[i]][i]-=a;
            Edge[i][pre[i]]+=a;
        }
        flow+=a;
    }
}
int main()
{
    int t,i,j,u,v,w,k=1;
    scanf("%d",&t);
    while(t--)
    {
        flow=0;
        memset(Edge,0,sizeof(Edge));
        scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            Edge[u][v]+=w;
        }
        ek();
        printf("Case %d: ",k++);
        printf("%d\n",flow);
    }
    return 0;
}


以上是关于HDU3549_Flow Problem(网络流/EK)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 3549 Flow Problem(最大流模板)

hdu 3549 Flow Problem(最大流模板题)

hdu 3549 Flow Problem (最大流入门题)

Flow Problem HDU - 3549

hdu 3549 Flow Problem (Dinic)

hdu 3549 Flow Problem