HDU1047 Integer Inquiry

Posted -

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1047 Integer Inquiry相关的知识,希望对你有一定的参考价值。

Problem Description
One of the first users of BIT‘s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,‘‘ remarked Chip. ``I only wish Timothy were here to see these results.‘‘ (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 
 

 

Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.
 

 

Output
Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

 

Sample Input
1
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
 
Sample Output
370370367037037036703703703670
 
Code:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <ctype.h>


using namespace std;

char num[105];
int sum[1000];

void add(char a[])
{
    int z=0;
    for(int i=strlen(a)-1;i>=0;i--)
    {
        sum[z]+=a[i]-0;
        sum[z+1]+=sum[z]/10;
        sum[z]%=10;
        z++;
    }
}
int main()
{
    int t,i;
    scanf("%d",&t);
    while(t--)
    {
        memset(num, ,sizeof(num));
        memset(sum,0,sizeof(sum));

        while(scanf("%s",num)&&strcmp(num,"0"))
            add(num);

        for(i=999;i>=0;i--)
            if(sum[i])
                break;
        if(i<0)
            printf("0");
        for(;i>=0;i--)
            printf("%d",sum[i]);
            printf("\n");
        if(t!=0)
            printf("\n");

    }
    return 0;
}

 

以上是关于HDU1047 Integer Inquiry的主要内容,如果未能解决你的问题,请参考以下文章

(大数 string) Integer Inquiry hdu1047

HDU 1047 Integer Inquiry 大数相加 string解法

1047 Integer Inquiry

HDU:Integer Inquiry

02:Integer Inquiry

UVA 424-Integer Inquiry