HDU1058 Humble Numbers(DP)

Posted -

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1058 Humble Numbers(DP)相关的知识,希望对你有一定的参考价值。

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 
Code:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <ctype.h>

#define max_size 5843
using namespace std;

long long num[max_size];

long long Min(long long a,long long b,long long c,long long d)
{
    long long min1,min2;
    min1=a<b?a:b;
    min2=c<d?c:d;

    if(min1<min2)
        return min1;
    else
        return min2;
}

int main()
{
    int i=1,p2,p3,p5,p7;
    p2=p3=p5=p7=1;
    num[1]=1;

    while(i<max_size)
    {
        num[++i]=Min(num[p2]*2,num[p3]*3,num[p5]*5,num[p7]*7);
        if(num[i]==num[p2]*2)
            p2++;
        if(num[i]==num[p3]*3)
            p3++;
        if(num[i]==num[p5]*5)
            p5++;
        if(num[i]==num[p7]*7)
            p7++;
    }

    int n;
    while(scanf("%d",&n)&&n)
    {
        if(n%10==1&&n%100!=11)
            printf("The %dst humble number is %lld.\n",n,num[n]);
        else if(n%10==2&&n%100!=12)
            printf("The %dnd humble number is %lld.\n",n,num[n]);
        else if(n%10==3&&n%100!=13)
            printf("The %drd humble number is %lld.\n",n,num[n]);
        else
            printf("The %dth humble number is %lld.\n",n,num[n]);
    }
    return 0;
}

 

以上是关于HDU1058 Humble Numbers(DP)的主要内容,如果未能解决你的问题,请参考以下文章

hdu1058 Humble Numbers

Humble Numbers HDU - 1058

HDU 1058 Humble Numbers

hdu1058Humble Numbers(动态规划)

hdu 1058 Humble Numbers

HDU 1058 Humble Numbers