HDU1042 N!(大整数类应用)

Posted -

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU1042 N!(大整数类应用)相关的知识,希望对你有一定的参考价值。

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

 

Input
One N in one line, process to the end of file.
 

 

Output
For each N, output N! in one line.
 

 

Sample Input
1
2
3
 

 

Sample Output
1
2
6
 
Code:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <ctype.h>


using namespace std;


int a[50000];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j,carry,len=1,t;
        memset(a,0,sizeof(a));
        a[0]=1;

        for(i=2;i<=n;i++)
        {
            for(carry=0,j=0;j<len;j++)
            {
                t=a[j]*i+carry;
                a[j]=t%10;
                carry=t/10;
            }
            while(carry)
            {
                a[j++]=carry%10;
                carry/=10;
                len++;
            }
        }
        for(j=len-1;j>=0;j--)
            printf("%d",a[j]);
        printf("\n");
    }
    return 0;
}

 

以上是关于HDU1042 N!(大整数类应用)的主要内容,如果未能解决你的问题,请参考以下文章

Q - N! HDU - 1042

HDU 1042N!

HDU 1042 N!

HDU - 1042 - N! - JAVA

N!(hdu1042)

HDU 1042 N!