强连通 反向建图 hdu3639

Posted Billyshuai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了强连通 反向建图 hdu3639相关的知识,希望对你有一定的参考价值。

Hawk-and-Chicken

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3321    Accepted Submission(s): 1041


Problem Description
Kids in kindergarten enjoy playing a game called Hawk-and-Chicken. But there always exists a big problem: every kid in this game want to play the role of Hawk.
So the teacher came up with an idea: Vote. Every child have some nice handkerchiefs, and if he/she think someone is suitable for the role of Hawk, he/she gives a handkerchief to this kid, which means this kid who is given the handkerchief win the support. Note the support can be transmitted. Kids who get the most supports win in the vote and able to play the role of Hawk.(A note:if A can win
support from B(A != B) A can win only one support from B in any case the number of the supports transmitted from B to A are many. And A can‘t win the support from himself in any case.
If two or more kids own the same number of support from others, we treat all of them as winner.
Here‘s a sample: 3 kids A, B and C, A gives a handkerchief to B, B gives a handkerchief to C, so C wins 2 supports and he is choosen to be the Hawk.
 

 

Input
There are several test cases. First is a integer T(T <= 50), means the number of test cases.
Each test case start with two integer n, m in a line (2 <= n <= 5000, 0 <m <= 30000). n means there are n children(numbered from 0 to n - 1). Each of the following m lines contains two integers A and B(A != B) denoting that the child numbered A give a handkerchief to B.
 

 

Output
For each test case, the output should first contain one line with "Case x:", here x means the case number start from 1. Followed by one number which is the total supports the winner(s) get.
Then follow a line contain all the Hawks‘ number. The numbers must be listed in increasing order and separated by single spaces.
 

 

Sample Input
2
4 3
3 2
2 0
2 1
 
3 3
1 0
2 1
0 2
 

 

Sample Output
Case 1:2
0 1
Case 2: 2
0 1 2
 
反向建图的原因是方便统计,倘若是正向的话 ,那么如果有2->3,3->1,2->1  2这个节点在计算的时候很难搞
#include<cstdio>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=5008;
const int M=30008;
int head[N],tot,scnt,cnt,cont,sz[N];
int dfn[N],low[N],bl[N],q[N],l;
bool instack[N],ru[N];
vector<int>G;
vector<int>C[N];
struct node{
   int to,next;
}e[M];
void add(int u,int v){
   e[tot].to=v;
   e[tot].next=head[u];
   head[u]=tot++;
}
void init(){
   tot=scnt=cnt=l=0;
   memset(head,-1,sizeof(head));
   memset(dfn,0,sizeof(dfn));
   memset(instack,0,sizeof(instack));
   memset(ru,0,sizeof(ru));
   G.clear();
   for(int i=0;i<N;++i) C[i].clear();
}
void Tajan(int u){
   dfn[u]=low[u]=++cnt;
   q[l++]=u;
   instack[u]=1;
   for(int i=head[u];i+1;i=e[i].next){
    int v=e[i].to;
    if(!dfn[v]) {
        Tajan(v);
        low[u]=min(low[u],low[v]);
    }
    else if(instack[v]&&dfn[v]<low[u])
        low[u]=dfn[v];
   }
   if(dfn[u]==low[u]) {
    ++scnt;
    int t;
    sz[scnt]=0;
    do{
        t=q[--l];
        bl[t]=scnt;
        ++sz[scnt];
        C[scnt].push_back(t);
        instack[t]=0;
    }while(t!=u);
   }
}
bool used[N];
void dfs(int u,int tz){
   for(int i=head[u];i+1;i=e[i].next)
   if(!used[e[i].to]){
    used[e[i].to]=1;
    sz[tz]+=sz[e[i].to];
    dfs(e[i].to,tz);
   }
}
struct point{
   int u,v;
}ee[M];
int main(){
    int n,m,u,v,T;
    scanf("%d",&T);
    for(int tas=1;tas<=T;++tas){
        init();
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;++i){
            scanf("%d%d",&u,&v);
            add(v,u);
        }
        for(int i=0;i<n;++i) if(!dfn[i]) Tajan(i);
        int pp=0;
        for(int i=0;i<n;++i)
        for(int j=head[i];j+1;j=e[j].next){
            int v=e[j].to;
            if(bl[i]==bl[v]) continue;
            else {ee[pp].u=bl[i];ee[pp++].v=bl[v];ru[bl[v]]=1;}
        }
        memset(head,-1,sizeof(head));
        tot=0;
        for(int i=0;i<pp;++i) add(ee[i].u,ee[i].v);
        int maxx=-1;
        for(int i=1;i<=scnt;++i)
        if(!ru[i]){
            memset(used,0,sizeof(used));
            dfs(i,i);
            if(maxx<sz[i]) {maxx=sz[i];G.clear(); for(int j=0;j<(int)C[i].size();++j) G.push_back(C[i][j]);}
        else if(maxx==sz[i]) for(int j=0;j<(int)C[i].size();++j) G.push_back(C[i][j]);
        }
        sort(G.begin(),G.end());
        printf("Case %d: %d\n",tas,maxx-1);
        for(int i=0;i<(int)G.size()-1;++i) printf("%d ",G[i]);
        printf("%d\n",G[(int)G.size()-1]);
    }
}

 

以上是关于强连通 反向建图 hdu3639的主要内容,如果未能解决你的问题,请参考以下文章

强连通分量

HDU 3861 The King's Problem(强连通分量缩点+最小路径覆盖)

Hawk-and-Chicken 强连通

「国庆训练」Bomb(HDU-5934)

hdu4857 逃生反向建图+拓扑排序

HDU 1269 迷宫城堡 tarjan算法求强连通分量