poj1995 Raising Modulo Numbers高速幂

Posted zhchoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj1995 Raising Modulo Numbers高速幂相关的知识,希望对你有一定的参考价值。

Raising Modulo Numbers
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 5500   Accepted: 3185

Description

People are different. Some secretly read magazines full of interesting girls‘ pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players‘ experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13


#include<stdio.h>
#include<string.h>
int ksm(long long a,long long b,long long n)
{
	long long ans=1;
	while(b)
	{
		if(b&1)
			ans=ans*a%n;
			//写成ans*=a%n不行...输出错误 
		a=a*a%n;
		b>>=1;
	}
	return ans;
}
int main()
{
	int z,h,m,u,i;
	scanf("%d",&z);
	while(z--)
	{
		int sum = 0;
		scanf("%d",&m);
		scanf("%d",&h);
		while(h--)
		{
			scanf("%d%d",&u,&i);
			sum += ksm(u,i,m);
			sum %= m;
		}
		printf("%d\n",sum);
	}
	return 0;
}

/*************************************************************/

#include<stdio.h>
#include<string.h>
int main()
{
	long long z,h,m,a,b,ans;
	scanf("%lld",&z);
	while(z--)
	{
		int sum = 0;
		scanf("%lld",&m);
		scanf("%lld",&h);
		while(h--)
		{
			scanf("%lld%lld",&a,&b);
			ans = 1;
			while(b)
			{
				if(b&1)
				ans=ans*a%m;
				a=a*a%m;
				b>>=1;
			}
			sum += ans;
			sum %= m;
		}
		printf("%d\n",sum%m);
	}
	return 0;
}




以上是关于poj1995 Raising Modulo Numbers高速幂的主要内容,如果未能解决你的问题,请参考以下文章

POJ1995 Raising Modulo Numbers

poj 1995 Raising Modulo Numbers 题解

Raising Modulo Numbers(POJ 1995 快速幂)

poj1995 Raising Modulo Numbers高速幂

POJ1995 Raising Modulo Numbers(快速幂)

POJ1995:Raising Modulo Numbers