POJ 1318

Posted 十年换你一句好久不见

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1318相关的知识,希望对你有一定的参考价值。

Word Amalgamation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4340    Accepted Submission(s): 2187


Problem Description
In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.
 

 

Input
The input contains four parts:

1. a dictionary, which consists of at least one and at most 100 words, one per line;
2. a line containing XXXXXX, which signals the end of the dictionary;
3. one or more scrambled `words‘ that you must unscramble, each on a line by itself; and
4. another line containing XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X‘s.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.
 

 

Output
For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line ``NOT A VALID WORD" instead. In either case, output a line containing six asterisks to signal the end of the list.
 

 

Sample Input
tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX
 
Sample Output
score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******
先给定一个字典,再给一堆字符,每一串字符随机组合成字典中的单词,若可以组合成则单词字典序输出,否则输出无效的单词,每一个单词查找完后输出一行******
容器+排序
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <cstdlib>
#include <iomanip>
#include <cmath>
#include <ctime>
#include <map>
#include <set>
using namespace std;
#define lowbit(x) (x&(-x))
#define max(x,y) (x>y?x:y)
#define min(x,y) (x<y?x:y)
#define MAX 100000000000000000
#define MOD 1000000007
#define pi acos(-1.0)
#define ei exp(1)
#define PI 3.141592653589793238462
#define INF 0x3f3f3f3f3f
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
map<string,int>m;
set<string>s[105];
set<string>::iterator it;
string str,rstr,name="XXXXXX";
int main()
{
    int tot=1;
    while(cin>>str)
    {
        if(str==name) break;
        rstr=str;
        sort(rstr.begin(),rstr.end());
        if(m[rstr]==0) m[rstr]=tot++;
        s[m[rstr]].insert(str);
    }
    while(cin>>str)
    {
        if(str==name)break;
        sort(str.begin(),str.end());
        if(m[str]==0) printf("NOT A VALID WORD\n******\n");
        else
        {
            for(it=s[m[str]].begin();it!=s[m[str]].end();it++)
                cout<<*it<<endl;
            printf("******\n");
        }
    }
    return 0;
}

 

以上是关于POJ 1318的主要内容,如果未能解决你的问题,请参考以下文章

poj 1318 Word Amalgamation

POJ-1318(list.sort()输出不为字典序,map才是按字典序排列)

POJ2778DNA Sequence(AC自动机)

POJ3691DNA repair(AC自动机,DP)

片段变化后失去焦点(ANDROID TV)

18.06.03 POJ 4126:DNA 15年程设期末05(状压DP)