HDU 5301(Buildings-贪心构造)

Posted brucemengbm

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5301(Buildings-贪心构造)相关的知识,希望对你有一定的参考价值。

Buildings

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2210    Accepted Submission(s): 624


Problem Description
Your current task is to make a ground plan for a residential building located in HZXJHS. So you must determine a way to split the floor building with walls to make apartments in the shape of a rectangle. Each built wall must be paralled to the building‘s sides.

The floor is represented in the ground plan as a large rectangle with dimensions n×m技术分享, where each apartment is a smaller rectangle with dimensions a×b技术分享 located inside. For each apartment, its dimensions can be different from each other. The numbera技术分享 and b技术分享 must be integers.

Additionally, the apartments must completely cover the floor without one 1×1技术分享 square located on (x,y)技术分享. The apartments must not intersect, but they can touch.

For this example, this is a sample of n=2,m=3,x=2,y=2技术分享.

技术分享


To prevent darkness indoors, the apartments must have windows. Therefore, each apartment must share its at least one side with the edge of the rectangle representing the floor so it is possible to place a window.

Your boss XXY wants to minimize the maximum areas of all apartments, now it‘s your turn to tell him the answer.
 

Input
There are at most 10000技术分享 testcases.
For each testcase, only four space-separated integers, n,m,x,y(1n,m10技术分享8技术分享,n×m>1,1xn,1ym)技术分享.
 

Output
For each testcase, print only one interger, representing the answer.
 

Sample Input
2 3 2 2 3 3 1 1
 

Sample Output
1 2
Hint
Case 1 :
技术分享
You can split the floor into five $1 \times 1$ apartments. The answer is 1. Case 2:
技术分享
You can split the floor into three $2 \times 1$ apartments and two $1\times 1$ apartments. The answer is 2.
技术分享
If you want to split the floor into eight $1 \times 1$ apartments, it will be unacceptable because the apartment located on (2,2) can‘t have windows.
 

Author
XJZX
 

Source
php?

field=problem&key=2015+Multi-University+Training+Contest+2&source=1&searchmode=source">2015 Multi-University Training Contest 2

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5395 5394 5393 5392 5391 
 

假设没有坏点 ans=(min(n,m)+1)/2

假设n=m=奇数,x,y在中间 ans‘=(min(n,m)+1)/2-1

否则,x,y用对称性挪到左上角

此时对于宿舍楼要么竖着分max(y,m-y+1)+1

要么横着分 min(x,n-x+1)




#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
#define Lson (x<<1)
#define Rson ((x<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (100000007)
typedef long long ll;
ll mul(ll a,ll b){return (a*b)%F;}
ll add(ll a,ll b){return (a+b)%F;}
ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}
int main()
{
//	freopen("B.in","r",stdin);
	
	int n,m,x,y;
	while(scanf("%d%d%d%d",&n,&m,&x,&y)==4) {
		if (n<m) swap(n,m),swap(x,y);
		
		int ans=(min(n,m)+1)/2;
		if (n==m&&x==y&&n==2*x-1) 
		{
			cout<<ans-1<<endl; continue;
		} 
		
		x=min(x,n-x+1),y=max(y,m-y+1);
		
		int ans2=min(x,y-1);
		
		cout<<max(ans2,ans)<<endl; 
		
	}	
	
	
	return 0;
}






































以上是关于HDU 5301(Buildings-贪心构造)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 5301 Buildings(2015多校第二场)

bzoj4302 Hdu 5301 Buildings

图解hdu5301Buildings

HDU-4296 Buildings 贪心 从相邻元素的相对位置开始考虑

H. Twin Buildings(贪心&扫描线)

2017 Multi-University Training Contest - Team 1 1002&&HDU 6034 Balala Power!字符串,贪心+排序(示例代码(代