Tempter of the bone

Posted 叶小七

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Tempter of the bone相关的知识,希望对你有一定的参考价值。

题目描述:

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

输入:

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
‘X‘: a block of wall, which the doggie cannot enter;
‘S‘: the start point of the doggie;
‘D‘: the Door; or
‘.‘: an empty block.
The input is terminated with three 0‘s. This test case is not to be processed.

输出:

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

样例输入:
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
样例输出:
NO
YES
提示:

 用scanf读取输入。

#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;
char maze[8][8];
int go[8][2]={
1,0,
-1,0,
0,1,
0,-1,
-1,-1,
1,1,
-1,1,
1,-1
};
int m,n,t;
bool suc;
void dfs(int x,int y,int time){
    for (int i=0;i<4;i++){
        int nx=x+go[i][0];
        int ny=y+go[i][1];
        if (nx<0||nx>=n||ny<0||ny>=m) continue;
        if (maze[nx][ny]==X ) continue;
        if (maze[nx][ny]==D){
            if (time+1==t){
                suc=true;
                return;
            }
            else continue;
        }
        maze[nx][ny]=X;
        dfs(nx,ny,time+1);
        maze[nx][ny]=.;
        if (suc) return;
    }
    return;
}

int main (){
    
    while (cin>>n>>m>>t && !(m==0&&n==0&&t==0)){
        int sx,sy,dx,dy;
        suc=false;
        for (int i=0;i<n;i++){ 
            for (int j=0;j<m;j++){
                cin>>maze[i][j];
                if (maze[i][j]==S){
                    sx=i;sy=j;
                }
                if (maze[i][j]==D){
                    dx=i;dy=j;
                }
                
            }
        }
        if ((sx+sy)%2==((dx+dy)%2+t%2)%2){
            maze[sx][sy]=X;
            dfs(sx,sy,0);
        }
        string s=suc==true?"YES":"NO";
        cout<<s<<endl;
    }

    return 0;
}

提示让用scanf输入,其实不用也可以

 

以上是关于Tempter of the bone的主要内容,如果未能解决你的问题,请参考以下文章

hdu 1010 Tempter of the Bone

Tempter of the Bone

1010:Tempter of the Bone

HDU 1010 Tempter of the Bone

ZOJ - 2110 Tempter of the Bone

Tempter of the Bone——DFS(王道)