Oil Deposit

Posted 叶小七

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Oil Deposit相关的知识,希望对你有一定的参考价值。

题目描述:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

输入:

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.

输出:

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

样例输入:
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
样例输出:
0
1
2
2
#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
char maze[101][101];
bool mark[101][101];
int go[8][2]={
1,0,
-1,0,
0,1,
0,-1,
-1,-1,
1,1,
-1,1,
1,-1
};
int m,n;
void dfs(int x,int y){
    for (int i=0;i<8;i++){
        int nx=x+go[i][0];
        int ny=y+go[i][1];
        if (nx<0||nx>=m||ny<0||ny>=n) continue;
        if (maze[nx][ny]==* || mark[nx][ny]==true) continue;
        mark[nx][ny]=true;
        dfs(nx,ny);
    }
    return;
}

int main (){
    
    while (cin>>m>>n && !(m==0&&n==0)){
        for (int i=0;i<m;i++){
            //getchar(); 
            for (int j=0;j<n;j++){
                //scanf("%c",maze[i][j]);
                cin>>maze[i][j];
                mark[i][j]=false;
            }
        }

        int ans=0;
        for (int i=0;i<m;i++){
            for (int j=0;j<n;j++){
                if (maze[i][j]==*) continue;
                if (mark[i][j]==true) continue;
                dfs(i,j);
                ans++;
            }
        }
        cout<<ans<<endl;
    }

    return 0;
}

 这种将相邻的点合成块的算法有一个专有名词,floodfill

以上是关于Oil Deposit的主要内容,如果未能解决你的问题,请参考以下文章

九度oj 题目1460:Oil Deposit

以太坊eth2 deposit merkle tree

Oil Deposits(油田问题)

DFS——hdu1241Oil Deposits

UVa 572 Oil Deposits(简单DFS)

BZOJ 1177 [Apio2009]Oil(递推)