POJ - 2785 :4 Values whose Sum is 0 (二分)

Posted 西北会法语

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ - 2785 :4 Values whose Sum is 0 (二分)相关的知识,希望对你有一定的参考价值。

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
 
输入四组数,问在四组数每组取一个数相加等于0的方法数。
将前两组和枚举排序,后两组和枚举。
二分查找排序后的数组即可,复杂度O(N^2)
 
源代码:
#include<iostream>
#include<algorithm>

using namespace std;

int a[4005],b[4005],c[4005],d[4005],e[16000005],f[16000005];

int main()
{
	int n;
	while(cin>>n)
	{
	
	int x=0,y=0,z,t;
	
	for(int i=0;i<n;i++)
		cin>>a[i]>>b[i]>>c[i]>>d[i];
	for(int i=0;i<n;i++)
		for(int j=0;j<n;j++)
		{
			e[x++]=a[i]+b[j];
			f[y++]=c[i]+d[j];
		}
	sort(e,e+x);
	long long int s=0;
	for(int i=0;i<y;i++)
	{
		s+=upper_bound(e,e+n*n,-f[i])-lower_bound(e,e+n*n,-f[i]);
	}
	cout<<s<<endl;
	}
	
	return 0;
}

 

以上是关于POJ - 2785 :4 Values whose Sum is 0 (二分)的主要内容,如果未能解决你的问题,请参考以下文章

poj 2785 4 Values whose Sum is 0

4 Values whose Sum is 0 :POJ - 2785

POJ 2785 4 Values whose Sum is 0(折半搜索)

4 Values whose Sum is 0 POJ - 2785

POJ 2785 4 Values whose Sum is 0

poj 2785 4 Values whose Sum is 0(折半枚举(双向搜索))