UVA 11461 Square Numbers解题报告

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了UVA 11461 Square Numbers解题报告相关的知识,希望对你有一定的参考价值。

Discription

A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive).

Input

The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤ b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.

Output

For each line of input produce one line of output. This line contains an integer which denotes how many square numbers are there between a and b (inclusive).

Sample Input

1 4

1 10

0 0

Sample Output

2

3

分析

很简单的数学题吧。(第一次参加校赛做的第一个题,波澜不惊地AC了.....)

AC代码

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

int main(int argc, char const *argv[])
{
	int a, b;
	while ((scanf("%d%d", &a, &b)) == 2)
	{
		if (a == 0 && b == 0)
			break;
		printf("%d\n", (int)(floor(sqrt(b)) - ceil(sqrt(a)) + 1));
	}
}	
	

  

以上是关于UVA 11461 Square Numbers解题报告的主要内容,如果未能解决你的问题,请参考以下文章

题解 UVa11461

LeetCode Sum of Square Numbers

#Leetcode# 633. Sum of Square Numbers

633. Sum of Square Numbers

633. Sum of Square Numbers

633. Sum of Square Numbers