Seinfeld(杭电3351)

Posted gccbuaa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Seinfeld(杭电3351)相关的知识,希望对你有一定的参考价值。

Seinfeld

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1382    Accepted Submission(s): 683


Problem Description
I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one.
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows:
1. An empty string is stable.
2. If S is stable, then {S} is also stable.
3. If S and T are both stable, then ST (the concatenation of the two) is also stable.
All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{.
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.
 

Input
Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)

 

Output
For each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
 

Sample Input
}{ {}{}{} {{{} ---
 

Sample Output
1. 2 2. 0 3. 1
#include<stdio.h>
#include<string.h>
int main()
{
    int k=1;
    int a,t,i,len;
    char str[2010];
    while(gets(str)&&str[0]!='-')
    {
        int a=t=0;
        len=strlen(str);
        for(i=0;i<len;i++)
        {
            if(str[i]=='{')
            {
                t++;
            }
            else
            {
                if(t)
                {
                    t--;
                }
                else
                {
                    t++;
                    a++;
                }
            }
        }
        a=a+t/2;
        printf("%d. %d\n",k,a);
        k++;
    }
    return 0;
}


以上是关于Seinfeld(杭电3351)的主要内容,如果未能解决你的问题,请参考以下文章

POJ3991 HDU3351 UVALive4733 Seinfeld水题

POJ 3991 Seinfeld

杭电acm的2073无限的路

杭电2018

hdoj3351-stack

杭电1002