NYOJ 题目94 cigarettes

Posted

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了NYOJ 题目94 cigarettes相关的知识,希望对你有一定的参考价值。

题目描述:

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. 
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it‘s n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124
大致意思是假设汤姆有n支香烟,每吸k支香烟就会得到一支新的香烟,求汤姆最多能吸多少支香烟?

#include<stdio.h>
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
int n,k,i;
int sum=0;
scanf("%d %d",&n,&k);
for(i=1;i<=n;i++)
{
sum=sum+1;
if(sum%k==0)
n=n+1;
}
printf("%d",sum);
printf("\n");
}
}

//AC

欢迎各路大神评论!

 

 


以上是关于NYOJ 题目94 cigarettes的主要内容,如果未能解决你的问题,请参考以下文章

NYOJ_94 cigarettes 递归VS迭代

NYOJ题目28大数阶乘

NYOJ题目27水池数目

NYOJ之题目1058部分和问题

NYOJ 题目56 阶乘式因式分解

NYOJ 2356 哈希计划(模拟)