How Many Tables 简单并查集

Posted 给杰瑞一块奶酪~

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了How Many Tables 简单并查集相关的知识,希望对你有一定的参考价值。

Today is Ignatius‘ birthday. He invites a lot of friends. Now it‘s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

InputThe input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
OutputFor each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4


#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
int n , m ;
int f[1001] ;
void init()
{
    for(int i = 1 ; i <= n ; i++)
    {
        f[i] = i ;
    }
}
int getf(int x)
{
    if(f[x] != x)f[x]=getf(f[x]);
    return f[x] ;
}
int merge(int x,int y)
{
    f[getf(y)]=getf(x);
}
int main()
{
    int T,x,y,c;
    scanf("%d" , &T);
    while(T--)
    {
        c=0;
        scanf("%d%d",&n,&m);
        init();
        for(int i = 1 ; i <= m ; i++)
        {
            scanf("%d %d",&x,&y);
            merge(x,y);
        }
        for(int i = 1 ; i <= n ; i++)
            if(f[i]==i)c++;
        printf("%d\n",c);
    }
}

 

以上是关于How Many Tables 简单并查集的主要内容,如果未能解决你的问题,请参考以下文章

hdu 1213 How Many Tables(并查集)

How Many Tables——并查集模板题

How Many Tables-并查集

How Many Tables//并查集

HDU - 1213 How Many Tables(并查集)

HDU - 1213 How Many Tables [并查集]