Bad Hair Day 单调栈
Posted 博客就叫Molex好了
tags:
篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Bad Hair Day 单调栈相关的知识,希望对你有一定的参考价值。
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 13562 | Accepted: 4576 |
Description
Some of Farmer John‘s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows‘ heads.
Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.
Consider this example:
= = = = - = Cows facing right --> = = = = - = = = = = = = = = 1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow‘s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow‘s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!
Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.
Input
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Sample Input
6 10 3 7 4 12 2
Sample Output
5
Source
题目大意:从左往右,每个牛都有一个高度,他能看到右边低于他高度的牛,问总共能看到多少,,
反着想,看这个牛能被多少牛看到,要是左边的有比他低或等于他就不被看到,直接去掉就好,
ac代码
- #include<stdio.h>
- #include<stack>
- #include<string>
- #include<iostream>
- using namespace std;
- int main()
- {
- int n;
- while(scanf("%d",&n)!=EOF)
- {
- int a[100010];
- int i;
- __int64 ans=0;
- stack<int>s;
- for(i=0;i<n;i++)
- {
- scanf("%d",&a[i]);
- }
- for(i=0;i<n;i++)
- {
- while(!s.empty()&&s.top()<=a[i])
- s.pop();
- ans+=s.size();
- s.push(a[i]);
- }
- printf("%I64d\n",ans);
- }
- }
以上是关于Bad Hair Day 单调栈的主要内容,如果未能解决你的问题,请参考以下文章
POJ3250[USACO2006Nov]Bad Hair Day[单调栈]