Cow Marathon(树的直径)

Posted 小时のblog

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Cow Marathon(树的直径)相关的知识,希望对你有一定的参考价值。

Cow Marathon
Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 5362   Accepted: 2634
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

Source

【思路】
求树的直径。树上最远两点距离。两边dfs。bfs也可。
W S E N 并没有什么卵用‘
【code】
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int n,m,x,y,z,head[40002],dad[40002],dis[40003],maxx,maxn,sumedge;
struct Edge
{
    int x,y,z,nxt;
    Edge(int x=0,int y=0,int z=0,int nxt=0):
        x(x),y(y),z(z),nxt(nxt){}
}edge[80009];
void add(int x,int y,int z)
{
    edge[++sumedge]=Edge(x,y,z,head[x]);
    head[x]=sumedge;
}
void dfs(int x)
{
    for(int i=head[x];i;i=edge[i].nxt)
    {
        int v=edge[i].y;
        if(dad[x]!=v)
        {
            dad[v]=x;
            dis[v]=dis[x]+edge[i].z;
            dfs(v);
        }
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        char s[4];
        cin>>x>>y>>z>>s[0];
        add(x,y,z);
        add(y,x,z);
    }
    dfs(1);
    maxx=-0x7fffff;
    for(int i=1;i<=n;i++)
    {
        if(dis[i]>maxx)
        {
            maxx=dis[i];
            maxn=i;
        }
    }
    memset(dis,0,sizeof(dis));
    memset(dad,0,sizeof(dad));
    dfs(maxn);
    maxx=-0x7fff;
    for(int i=1;i<=n;i++)
    {
        if(dis[i]>maxx)
        {
            maxx=dis[i];
        }
    }
    printf("%d\n",maxx);
    return 0;
} 

 

以上是关于Cow Marathon(树的直径)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1985 Cow Marathon(树的直径)

poj:1985:Cow Marathon(求树的直径)

BZOJ 3363 POJ 1985 Cow Marathon 树的直径

树的直径 bzoj3363[Usaco2004 Feb]Cow Marathon 奶牛马拉松

poj1985 Cow Marathon

POJ1985Cow Marathon