HDU 1031.Design T-Shirt结构体二次排序8月21

Posted yangykaifa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 1031.Design T-Shirt结构体二次排序8月21相关的知识,希望对你有一定的参考价值。

Design T-Shirt

Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people‘s opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
 

Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person‘s satisfaction on the j-th element.
 

Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
 

Sample Input
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
 

Sample Output
6 5 3 1 2 1
n个人,m件衣服,输出评价最高的前k件,输出时,评价同样的标号大的先输出。一定要二次排,由于可能所有的评价一样高,仅仅排一次输出就会有错误。

代码例如以下:

#include<cstdio>
#include<algorithm>
using namespace std;
struct ss{
    double v;
    int x;
};
bool cmp1(ss x,ss y){
    if(x.v>y.v) return true;
    else return false;
}
bool cmp2(ss x,ss y){
    if(x.x>y.x) return true;
    else return false;
}
int main(){
    int n,m,k;
    double t;
    ss f[1010];
    while(scanf("%d%d%d",&n,&m,&k)==3){
        for(int i=0;i<m;i++)
            f[i].v=0;
        while(n--)
        for(int i=0;i<m;i++){
            scanf("%lf",&t);
            f[i].v+=t;
            f[i].x=i+1;
        }
        sort(f,f+m,cmp1);
        sort(f,f+k,cmp2);//二次排。仅仅排前k项
        for(int i=0;i<k;i++){
            if(i!=0) printf(" ");
            printf("%d",f[i].x);
        }
        printf("\n");
    }
    return 0;
}
技术分享









以上是关于HDU 1031.Design T-Shirt结构体二次排序8月21的主要内容,如果未能解决你的问题,请参考以下文章

HDU 1031.Design T-Shirt结构体二次排序8月21

hdoj-1031-Design T-Shirt

HDU 2544 最短路

hdu2544

hdu-2544 最短路

最短路(hdu2544)