1078. Hashing (25)Hash + 探测——PAT (Advanced Level) Practise

Posted 闲云阁

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了1078. Hashing (25)Hash + 探测——PAT (Advanced Level) Practise相关的知识,希望对你有一定的参考价值。

题目信息

1078. Hashing (25)

时间限制100 ms
内存限制65536 kB
代码长度限制16000 B
The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be “H(key) = key % TSize” where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=10^4) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -

解题思路

题目默认你已掌握平方二次探测,有多坑逼,,,,

AC代码

#include <cstdio>
#include <cmath>
bool a[20005];
bool prime(int a){
    if (1 == a) return false;
    if (2 == a || 3 == a) return true;
    int t = (int)sqrt(a);
    for (int i = 2; i <= t; ++i){
        if (a%i == 0){
            return false;
        }
    }
    return true;
}
int main()
{
    int ms, n, ts, t, i, j;
    scanf("%d%d", &ms, &n);
    ts = ms;
    while (!prime(ts)){
        ++ts;
    }
    for (i = 0; i < n; ++i){
        scanf("%d", &t);
        for (j = 0; j < n; ++j){
            if (!a[(t + j*j) % ts]){
                a[(t + j*j) % ts] = true;
                printf("%s%d", i ? " ":"", (t + j*j) % ts);
                break;
            }
        }
        int loc = t % ts;
        if (j == n){
            printf("%s-", i ? " ":"");
        }
    }
    return 0;
}

以上是关于1078. Hashing (25)Hash + 探测——PAT (Advanced Level) Practise的主要内容,如果未能解决你的问题,请参考以下文章

1078. Hashing (25)-PAT甲级真题

PAT (Advanced Level) 1078. Hashing (25)

A1078 Hashing (25分)(哈希表平方探测法)

PAT 1078 Hashing[一般][二次探查法]

1078 Hashing (25 分)难度: 一般 / 知识点: 哈希表二次探测法

1078 Hashing