HDU 5289 Assignment(多校联合第一场1002)

Posted claireyuancy

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 5289 Assignment(多校联合第一场1002)相关的知识,希望对你有一定的参考价值。

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 617    Accepted Submission(s): 314


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test。output the number of groups.
 

Sample Input
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Author
FZUACM
 

Source
php?

field=problem&key=2015+Multi-University+Training+Contest+1&source=1&searchmode=source" style="color:rgb(26,92,200); text-decoration:none">2015 Multi-University Training Contest 1





#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int n,k;
int a[100100];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        __int64 sum = 0;
        scanf("%d%d",&n,&k);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        int bmax,bmin;
        for(int i=0; i<n; i++)
        {
            int max = a[i],min = a[i];
            bmax = i;
            bmin = i;
            int j;
            for(j=i; j<n; j++)
            {
                if(max<a[j])
                {
                    bmax = j;
                    max = a[j];
                }
                if(min > a[j])
                {
                    bmin = j;
                    min = a[j];
                }
                if(max-min >=k)
                {
                    int k2 = 1;
                    int k1 = 1;
                    if(bmax>bmin)
                    {
                        for(int v=i; v<bmax; v++)
                        {
                            sum += k1++;
                        }
                        for(int v=bmin+1;v<bmax;v++)
                        {
                            sum -= k2++;
                        }
                        i = bmin;
                    }
                    else
                    {
                        for(int v=i; v<bmin; v++)
                        {
                            sum += k1++;
                        }
                        for(int v=bmax+1;v<bmin;v++)
                        {
                            sum -= k2++;
                        }
                        i = bmax;
                    }
                    break;
                }
            }
            if(j == n)
            {
                int pk = 1;
                for(int v=i;v<n;v++)
                {
                    sum += pk++;
                }
                i = n;
                break;
            }
        }
        printf("%I64d\n",sum);
    }
    return 0;
}





 

以上是关于HDU 5289 Assignment(多校联合第一场1002)的主要内容,如果未能解决你的问题,请参考以下文章

HDU 5289 Assignment

HDU 5289 Assignment

HDU - 5289 Assignment (RMQ+二分)

HDU 5289 Assignment(二分+RMQ-ST)

HDU 5289 Assignment(单调队列)

hdu5289 Assignment (区间查询最大值最小值,st算法...)