POJ 1936 All in All(串)

Posted slgkaifa

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了POJ 1936 All in All(串)相关的知识,希望对你有一定的参考价值。

All in All
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 27537
Accepted: 11274

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

Source

Ulm Local 2002
水一个。

。。


就是推断字符串st1是不是字符串st2的字串。

#include <iostream>
using namespace std;
int main()
{
	char st1[100000],st2[100000];
    __int64 l1,l2,i,j;
	while(cin>>st1>>st2)
	{   i=0;j=0;
		l1=strlen(st1);
		l2=strlen(st2);
		while(1)
		{
			if(i==l1)
			{
				printf("Yes\n");
				break;
			}
			if(i<l1&&j==l2)
			{
				printf("No\n");
				break;
			}
			if(st1[i]==st2[j])
			{
				i++;j++;
			}
			else
				j++;
		}
	}
	return 0;
}

以上是关于POJ 1936 All in All(串)的主要内容,如果未能解决你的问题,请参考以下文章

POJ 1936 All in All 匹配, 水题 难度:0

POJ 1936 All in All

[POJ1936]All in All

UVa 10340 All in All (水题,匹配)

子串字谜 · Find All Anagrams in a String

POJ1936