Blocks

Posted yodel

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Blocks相关的知识,希望对你有一定的参考价值。

 
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6740   Accepted: 3276

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2
1
2

Sample Output

2
6
#include <iostream>
using namespace std;
const int mod=10007;
int pow(int a,int b){//quilck_^
    int ans=1,p=a;//make ans as 1,p as a
    while(b){//if b isnot 0 ,just go on
        if(b%2==1)ans=(ans*p)%mod;//if b is an odd number ,
        //just let the ans multiply the given base_number and % the given mod
        //!!if you don‘t %,maybe it at first larger than the range of int
        b=b/2;p=(p*p)%mod;//let the index been divided by 2
        //and renew the p ,and let it % the given mod
        }    //if b is 0 , just means has ^ already ,just break
    return ans;    //then return the ans
  }
int main(){int t;
    scanf("%d",&t);//given case_number
    while(t--){int n;scanf("%d",&n);//depend on the case_number 
        printf("%d\n",(pow(4,n-1)+pow(2,n-1))%mod);    
        //after matrix eigenvalues 
    }return 0;    
} 
//4^n=(2+1+1)^4,ans=sum[i=0...n]
//(c(n,i)2^i*sum[k=n-i and it is an even_number,t=0,2,...k](c(k,t) );
//at last work out 4^(n-1)+2^(n-1)。
//blocks

program is above, the program is the best language

以上是关于Blocks的主要内容,如果未能解决你的问题,请参考以下文章

控件集合无法修改,因为控件包含代码块(即 <% ... %>)

[OC学习笔记]Blocks

Code::Blocks 中的头文件和源文件问题

CentOS 7 编译安装 Code::Blocks

code::blocks 编辑代码是的光标颜色如何更改?

Code::Blocks 在“递归添加文件”到空项目后崩溃