HDU 3374 String Proble

Posted 十年换你一句好久不见

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了HDU 3374 String Proble相关的知识,希望对你有一定的参考价值。

String Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3183    Accepted Submission(s): 1295


Problem Description
Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

 

Input
  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
 

 

Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

 

Sample Input
abcder
aaaaaa
ababab
 

 

Sample Output
1 1 6 1
1 6 1 6
1 3 2 3
求循环节,并求字典序最大最小出现的次数
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <set>
#include <vector>
#include <queue>
using namespace std;
typedef long long ll;
char a[1000010];
int p[1000010];
void getnext()
{
  int i=0,j=-1;
  p[0]=-1;
  while(a[i]!=\0)
  {
    if(j==-1 || a[i]==a[j])
      p[++i]=++j;
    else j=p[j];
  }
}
int check(bool flag)
{
  int i=0,j=1,k=0;
  while(i<strlen(a) && j<strlen(a) && k<strlen(a))
  {
    int t=a[(j+k)%strlen(a)]-a[(i+k)%strlen(a)];
    if(t==0) k++;
    else
    {
      if(flag)
      {
        if(t>0) j+=k+1;
        else i+=k+1;
      }
      else
      {
        if(t<0) j+=k+1;
        else i+=k+1;
      }
      if(i==j) j++;
      k=0;
    }
  }
  return min(i,j);
}
int main()
{
  while(scanf("%s",a)!=EOF)
  {
    int minn=check(true);
    int maxn=check(false);
    getnext();
    int ans=(strlen(a)%(strlen(a)-p[strlen(a)]))==0?strlen(a)/(strlen(a)-p[strlen(a)]):1;
    printf("%d %d %d %d\n",minn+1,ans,maxn+1,ans);
  }
  return 0;
}

 

以上是关于HDU 3374 String Proble的主要内容,如果未能解决你的问题,请参考以下文章

hdu 3374 String Problem

hdu3374 String Problem最小表示法exKMP

hdu P3374 String Problem

hdu3374 String Problem(最小值表示法 + KMP)

hdu3374 String Problem 最小最大表示法 最小循环节出现次数

hdu 3374