Training little cats

Posted yodel

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了Training little cats相关的知识,希望对你有一定的参考价值。

Training little cats

Facer‘s pet cat just gave birth to a brood of little cats. Having considered the health of those lovely cats, Facer decides to make the cats to do some exercises. Facer has well designed a set of moves for his cats. He is now asking you to supervise the cats to do his exercises. Facer‘s great exercise for cats contains three different moves:
g i : Let the ith cat take a peanut.
e i : Let the ith cat eat all peanuts it have.
s i j : Let the ith cat and jth cat exchange their peanuts.
All the cats perform a sequence of these moves and must repeat it m times! Poor cats! Only Facer can come up with such embarrassing idea. 
You have to determine the final number of peanuts each cat have, and directly give them the exact quantity in order to save them.

Input

The input file consists of multiple test cases, ending with three zeroes "0 0 0". For each test case, three integers n, m and k are given firstly, where n is the number of cats and k is the length of the move sequence. The following k lines describe the sequence.
(m≤1,000,000,000, n≤100, k≤100)

Output

For each test case, output n numbers in a single line, representing the numbers of peanuts the cats have.

Sample Input

3 1 6
g 1
g 2
g 2
s 1 2
g 3
e 2
0 0 0

Sample Output
2 0 1
#include <cstdio>
#include <cstring>
#define ll long long
struct matrix{ll m[105][105];}a;
int n, k;
ll m;
// n:cat_num ,k:operation_num , m:operation_times
matrix multiply(matrix x,matrix y)
{
    matrix ans;//set an inside_ans to mark the solution
    memset(ans.m,0,sizeof(ans.m));//initialization the ans
    for(int i=1;i<=n;i++)for(int j=1;j<=n;j++)    
            if(x.m[i][j])//if can operate    
                for(int k=1;k<=n;k++)//just operate it    
                    ans.m[i][k]+=x.m[i][j]*y.m[j][k];    
                //matrix_multiply_above
    return ans;//at last ,return the ans 
}  
matrix quickmod(int p)
{
    matrix ans;//set an inside_ans to mark the solution  
    memset(ans.m,0,sizeof(ans.m));//initialization the ans
    for(int i=1;i<=n;i++)ans.m[i][i]=1;//initialization the map
    while(p)//if p !=0 , just go on
    {
        //bit operation 
        if(p&1)//just as if(p%2==1)
        ans=multiply(ans,a);//renew the base_number
        p>>=1;//just as p/=2
        a=multiply(a,a);//this operation lower the index amd renew the base_number
    } // if p==0, it means that we have operation p times already
    //this paragraph add the quilk_^_operation 
    return ans;//at last ,return the ans
}  
int main(){ll tmp;
    while(scanf("%d %lld %d",&n,&m,&k)!=EOF&&(n+m+k))
    //if read case ,and n,m,k!=0,just go on
    {   n++;
        char s[10];int x,y;memset(a.m,0,sizeof(a.m));
        for(int i=1;i<=n;i++)a.m[i][i]=1;//initialization the map,one wide more
        //the more list is mark how many peanuts it have
        for(int i=0;i<k;i++){
           scanf("%s",s);//read an order
            if(s[0]==g)//case 1:take a peanut
            scanf("%d", &x),a.m[x][n]++;
            //read the i,and let it get a peanut
            if(s[0]==e)//case 2:eat all the peanuts
            {
               scanf("%d",&x);//read the i
                for(int j=1;j<=n;j++)a.m[x][j]=0;
                //then set it‘s peanuts to 0
                //this line turn 0, no operation it has
            }
            if(s[0]==s)//case 3:change two cats‘ peanuts
            {
                scanf("%d %d",&x,&y);//read i and j
                for(int j=1;j<=n;j++)//then change their every operation 
                tmp=a.m[x][j],a.m[x][j]=a.m[y][j],a.m[y][j]=tmp;
            }
        }matrix ans=quickmod(m);//set a out_side ans to inherit function_inside_ans 
        for(int i=1;i<n;i++)printf("%lld ",ans.m[i][n]);printf("\n");
        //against every cat,printf it‘s peanuts_num
    }

program is above,the program is the best language

以上是关于Training little cats的主要内容,如果未能解决你的问题,请参考以下文章

POJ 3735 Training little cats 矩阵快速幂

POJ-3735 Training little cats(矩阵快速幂)

poj 3735 Training little cats (矩阵快速幂)

poj3735—Training little cats(特殊操作转化为矩阵操作)

TZOJ--5480: 孤衾易暖 // POJ--3735 Training little cats (矩阵快速幂)

poj 3735 Training little cats 矩阵快速幂+稀疏矩阵乘法优化