hdu 5078 Osu!(鞍山现场赛)

Posted zhchoutai

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了hdu 5078 Osu!(鞍山现场赛)相关的知识,希望对你有一定的参考价值。

Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 20    Accepted Submission(s): 15
Special Judge


Problem Description
Osu! is a very popular music game. Basically, it is a game about clicking. Some points will appear on the screen at some time, and you have to click them at a correct time.

技术分享

Now, you want to write an algorithm to estimate how diffecult a game is.

To simplify the things, in a game consisting of N points, point i will occur at time ti at place (xi, yi), and you should click it exactly at ti at (xi, yi). That means you should move your cursor from point i to point i+1. This movement is called a jump, and the difficulty of a jump is just the distance between point i and point i+1 divided by the time between ti and ti+1. And the difficulty of a game is simply the difficulty of the most difficult jump in the game.

Now, given a description of a game, please calculate its difficulty.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 1000) denoting the number of the points in the game.  Then N lines follow, the i-th line consisting of 3 space-separated integers, ti(0 ≤ ti < ti+1 ≤ 106), xi, and yi (0 ≤ xi, yi ≤ 106) as mentioned above.
 

Output
For each test case, output the answer in one line.

Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
2 5 2 1 9 3 7 2 5 9 0 6 6 3 7 6 0 10 11 35 67 23 2 29 29 58 22 30 67 69 36 56 93 62 42 11 67 73 29 68 19 21 72 37 84 82 24 98
 

Sample Output
9.2195444573 54.5893762558
Hint
In memory of the best osu! player ever Cookiezi.
 


求最大难度,难度为相邻两点的距离除以时间差。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <math.h>
using namespace std;
double a[10000];
double b[10000];
int ti[10000];
double dis(int i,int j)
{
    return sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        double ans=0;

        for(int i=0;i<n;i++)
        {
            scanf("%d%lf%lf",&ti[i],&a[i],&b[i]);
        }
        for(int i=1;i<n;i++)
        {
            ans=max(ans,(dis(i-1,i)/(ti[i]-ti[i-1])));
        }
        printf("%.10f\n",ans);
    }
    return 0;
}


























以上是关于hdu 5078 Osu!(鞍山现场赛)的主要内容,如果未能解决你的问题,请参考以下文章

hdu 5073 Galaxy(2014 鞍山现场赛)

hdu 5078

2014ACM/ICPC亚洲区鞍山赛区现场赛题解报告

2014ACM/ICPC亚洲区鞍山赛区现场赛题解报告

2014ACM/ICPC亚洲区鞍山赛区现场赛——题目重现

hdu 5538 House Building(长春现场赛——水题)