poj 3264

Posted Dysania_l

tags:

篇首语:本文由小常识网(cha138.com)小编为大家整理,主要介绍了poj 3264相关的知识,希望对你有一定的参考价值。

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

解题思路;
求区间最值直接用ST算法就行了。
模板:
#include<bits/stdc++.h>

using namespace std;

#define MAXN 50010
#define Max(x,y) (x>y?x:y)
#define Min(x,y) (x>y?y:x)

int maxsum[MAXN][20],minsum[MAXN][20];//表示从第i个数起连续2^j个数中的最大值/最小值

void RMQ(int num)
{
    for(int j=1;j<20;j++)
        for(int i=1;i<=num;i++)
        {
            if(i+(1<<j)-1 <= num)
            {
                maxsum[i][j]=Max(maxsum[i][j-1],maxsum[i+(1<<(j-1))][j-1]);
                minsum[i][j]=Min(minsum[i][j-1],minsum[i+(1<<(j-1))][j-1]);
            }
        }
}

int main()
{
    int i,j,num,t,query;
    while(scanf("%d%d",&num,&query) != EOF)
    {
        for(i=1;i<=num;i++)
        {
            scanf("%d",&maxsum[i][0]);
            minsum[i][0]=maxsum[i][0];
        }
        RMQ(num);
        int st,en,maxl,minl;
        while(query--)
        {
            scanf("%d%d",&st,&en);
            int k=(int)(log(en-st+1)/log(2.0));
            maxl=Max(maxsum[st][k],maxsum[en-(1<<k)+1][k]);
            minl=Min(minsum[st][k],minsum[en-(1<<k)+1][k]);
            printf("%d\n",maxl-minl);
        }
    }
    return 0;
}

 

以上是关于poj 3264的主要内容,如果未能解决你的问题,请参考以下文章

poj3264------线段树

POJ3264 Balanced Lineup

RMQ 模板题 poj 3264

POJ3264 Balanced Lineup

POJ 3264 Balanced Lineup

poj 3264 RMQ